How to kill a notebook process

1496
5
11-19-2021 12:47 PM
ChrisCowin
New Contributor III

I've tried everything I can think of to kill a running notebook that is stuck in a loop and nothing works. The Interrupt Kernel button is always grayed out, tried restarting the kernel through the command prompt (P Key) but this doesnt seem to do anything either. The only way I've figured out how to stop the process is to kill the entire application in task manager.

5 Replies
jcarlson
MVP Honored Contributor

In the task manager, can you see and kill the python process specifically? Still not a pretty solution, but perhaps better than killing the entire application.

- Josh Carlson
Kendall County GIS
0 Kudos
ChrisCowin
New Contributor III

Also gave this a shot, but it doesn't work. The process doesn't stop the loop.

0 Kudos
DanPatterson
MVP Esteemed Contributor

esc P

does it look like this?

restart_kernel1.png


... sort of retired...
ChrisCowin
New Contributor III

@DanPatterson, Yeah I tried the "confirm restart kernel" and on the notebook it seemed like it stopped but the code was still selecting features after it was restarted.

0 Kudos
FFollett
New Contributor

Chris, did you ever figure this issue out?  I've got similar behavior.  My interrupt kernel button is always greyed out when the kernel is busy.  I've tried using the keyboard shortcut (I, I) as Dan recommended, and this does get rid of the asterisk next to a cell denoting that it's running, but the kernel itself doesn't stop, meaning I still can't run any other cells.