How do I enable Z-values after a feature class has already been created and populated with data?

957
6
Jump to solution
09-10-2021 07:38 AM
Labels (3)
DevRobinson
New Contributor II

I am working with a polyline feature class that was created without enabling Z-Values, and I need to keep all of that data in tact, as I am trying to draw vertical lines in the feature class that will interact with the data. However, the option to draw vertical is grayed out when I right-click while creating a new simple line. I tried exporting the feature class data to a new feature class and giving it the same coordinate system and I even enabled Z-Values and checked that they were indeed enabled. Nonetheless, the option to draw vertical is still grayed out. 

I have tweaked every Source setting to match a freshly created Z-enabled feature class. All settings are the same, which leaves me with no apparent reason I cannot draw vertical. The line data already on the map even seem to have vertices that match the elevational ground surface, so I am completely stumped here, folks. 

Does anyone know how to draw vertical lines in a polyline feature class that was created without enabling Z-Values? 

I found an old Esri support article for how to add Z-Values in the old ArcMap, but trying it with ArcGIS Pro did not work as it would not allow me to specify the output format. Below is the article link. https://support.esri.com/en/technical-article/000012300

0 Kudos
1 Solution

Accepted Solutions
SamanthaGoodchild-Brown
New Contributor III

I'm pulling at straws here. have you checked out your properties? Wondering if display settings is over-riding that eg, makes the data 'display on the ground' is set instead of 'absolute values'.

View solution in original post

6 Replies
SamanthaGoodchild-Brown
New Contributor III

HI

First question I need to ask is: are you doing this in a scene or in a map view? It will not work in a map view, you must be in a scene.

Secondly, if you look at your attribute table, is it polylineZ? It must be.

These are the first thigs to check out and the first things that people slip up on.

0 Kudos
DevRobinson
New Contributor II

Hi, thank you for responding. Yes, they are in a local scene. And yes, it is PolylineZ after I exported. 

0 Kudos
David_Brooks
MVP Regular Contributor

@DevRobinson can you not run the Feature to 3D by Attribute tool to convert to 3D based on a z value in your data? that will then create a Z enabled feature class,


David
..Maps with no limits..
DevRobinson
New Contributor II

My data does not have a Height Field to select for this tool. After I exported as a new feature class I enabled Z-Values and the vertices of my line data follow the Ground Elevational Surface I have, so it seems like Z-Values are indeed enabled. But I still cannot draw vertical lines like I should be able to in a Z-enabled feature class. 

Thanks,

Dev

0 Kudos
SamanthaGoodchild-Brown
New Contributor III

I'm pulling at straws here. have you checked out your properties? Wondering if display settings is over-riding that eg, makes the data 'display on the ground' is set instead of 'absolute values'.

DevRobinson
New Contributor II

Uhhhhhhh, well that was it! Was staring me in the face the whole time. Under Properties and then Elevation, I had the layer set to 'On the ground' and upon selecting 'At an absolute height' or 'Relative to the ground' I was able to use the vertical line drawing tool. And Relative to the ground allowed the data to retain the correct elevation on my elevational surface. Thank you very much! 

0 Kudos