Geodatabase features disappear when zooming in ArcGIS Pro

1464
2
01-14-2020 01:05 AM
OraneRoché
New Contributor II

Hi all,

We have a problem in ArcGIS Pro (currently 2.4.2, but we had this problem on previous versions). Our layers disappear randomly when zooming in the map window.

Sometimes the layers fully disappear, sometimes it is just like a small part of it (a cache tile?). Sometimes, refreshing the map brings back the layers, sometimes not.

It is just a visualization problem : the data is still in the map, we can see its attribute table, and we can select it.

Our data is on a Posgresql 10.10 database. We don’t have the problem with an Oracle database, a filegdb, nor a shapefile.

We don’t have the problem on ArcMap.

We tried a lot of things already :

- All the cache options in the layer properties

- Destroying and recreating the spatial index (it seems to be working for some similar problems : https://support.esri.com/en/technical-article/000006099)

- Update the database

- sde update (now our sde schema is in 10.7)

- Different graphic cards and computers
- Different ArcGIS Pro versions

- Change the coordinate system

- Use heavy aprx with a lot of layers, or just light aprx with one layer

This is a major problem for us, because our ArcGIS Pro users are loosing their minds over this… and we are kinda desperate.

Is there someone out there who has or had the same problem ?

Thanks

Orane

ArcGIS Pro - Layer disappearing (cache tile)

2 Replies
AZendel
Occasional Contributor III

I've had this happen - or something similar. But not on Postgres. I'm pretty certain I was using a file geodatabase. It turned out to be bad geometry in some of the features. They cropped up after I ran the erase tool. When I ran "check geometry", a number of polygons were flagged as self-intersecting. Once I used the "repair geometry", the problem stopped. 

It's my understanding that all SDE instances validate geometry before they are inserted. So in theory, this shouldn't be happening with Postgres. But I could be wrong on that....

0 Kudos
MiroUmlauf
New Contributor II

I have the same problem and desperation, but with SQL Server. Lines randomly disappear in ArcGIS Pro (2.4 and 2.6) when zooming in / out. Recalculating or completely recreating spatial index does not fix it. In ArcMap all works well and as expected. I have imported these layers from PostgreSQL (outside of ESRI geodatabase) where I checked validity and simplicity, in other than ESRI software also all works great. I will try to use ESRI tools to check and repair geometry as AZendel recommended, as I guess that is the last thing I can do on my side.

 

Update:  As Esri presumes there can't be such thing as invalid geometry in Esri enterprise geodatabase, there are no tools to check / make sure. All tools on database level both in PostgreSQL and SQL server claim geometries are valid. Also as everything works great in ArcMap and non-Esri software, it must be ArcGIS Pro bug.

0 Kudos