Select to view content in your preferred language

Generate tile cache tiling scheme error 000241

762
7
Jump to solution
10-16-2023 01:32 PM
Blevins_Mark
Occasional Contributor

Im trying to generate a tile cache tiling scheme for an image collection in pro 3.1.3. Whenever i try, i recieve error 000241: "the specified path name or file type is invalid for the required input." I've tried tif, mosaic dataset, "raster" file types, nothing works. Anyone know why? Thanks.

0 Kudos
1 Solution

Accepted Solutions
GordonSumerling
Esri Regular Contributor

@Blevins_Mark For Elevation We generally use the LERC compressed tile cache while for 3 Band RGB we use the mixed format (jpg & Png). This allows for transparency along the edges. Additionally, I can't see a coordinate system in your images.

If you are using WGS84 Web Mercator then I would suggest just using the Manage Tile Cache tool and Pick Elevation Tiling Scheme for the DSM and ArcGIS Online Tiling Scheme for the Ortho.  These then use LERC by default for Elevation and Mixed for the Ortho.

View solution in original post

7 Replies
DanPatterson
MVP Esteemed Contributor

Can you provide the path name and file type and the input type?


... sort of retired...
0 Kudos
Blevins_Mark
Occasional Contributor

In the images below, you can see how it gives the error on the image file, but there is no error when i choose the dem file. Both are .tif files. Thank you.

 

dem.pngimg.png

0 Kudos
Blevins_Mark
Occasional Contributor

I think it was because i had the tile format set to LERC for the image, which i dont think is compatible with an image. Changing to one of the other formats gets rid of the error. Sorry, my oversight. Thanks.

0 Kudos
GordonSumerling
Esri Regular Contributor

@Blevins_Mark For Elevation We generally use the LERC compressed tile cache while for 3 Band RGB we use the mixed format (jpg & Png). This allows for transparency along the edges. Additionally, I can't see a coordinate system in your images.

If you are using WGS84 Web Mercator then I would suggest just using the Manage Tile Cache tool and Pick Elevation Tiling Scheme for the DSM and ArcGIS Online Tiling Scheme for the Ortho.  These then use LERC by default for Elevation and Mixed for the Ortho.

Blevins_Mark
Occasional Contributor

@GordonSumerling Thanks, that is pretty much what I did, except that my scene was a local one so I used a custom tile scheme so both the dem and image where in the same projection in the scene. Thanks, I received the error because I forgot to change the format from lerc to mixed on the image, so that was on me. 

0 Kudos
Blevins_Mark
Occasional Contributor

@GordonSumerling actually do you know how i can get the image to not "extrude" the edges? Thanks.

Capture.JPG

 

0 Kudos
Blevins_Mark
Occasional Contributor

@GordonSumerling nevermind i found this and making the footprint of the image a bit smaller than the ground layer resolved the issue. thanks.

https://support.esri.com/en-us/bug/when-an-arcgis-pro-scene-with-a-custom-elevation-layer-bug-000138...