Select to view content in your preferred language

Generate Schema Report - Error 002869

05-21-2024 12:28 PM
New Contributor II

I'm trying to run Generate Schema Report.  I tested it a month ago and it worked fine.  But now, every time I run it, an output error says, "Error 002869  Output file <filename> already exists."  No matter what name I give it, it says the file exists.  I've never seen such a thing.  I'm running ArcGIS Pro 3.3.0 on a desktop PC.

The input is a GDB and I'm trying to output an HTML file.  As I said, it worked last month so I don't think the file types are the problem.  I tried changing the output location as well, that didn't help.

0 Kudos
2 Replies
Esri Notable Contributor

I'm using ArcGIS Pro 3.3 and testing the Generate Schema Report GP tool on a fGDB FC and an eGDB FC where the output is an HTML file.  I run the tool once, it creates the output file.  If I don't delete the HTML file in File Explorer, then it throws the error code you listed.  If I do delete the HTML file in File Explorer (and the GP window is still open), name the output file the same name as the first time, it runs just fine.  

I wonder since you're seeing this now in 3.3, maybe you should do a soft reset of ArcGIS Pro to see if this clears the error message.

0 Kudos
New Contributor II

Problem solved, sort of.  The tool works and it outputs the HTML file I was expecting, but I still  get the error saying the file name already exists.  It’s been suggested that the error comes up in case I want to run the tool again using the same file name, but I’ve never seen that before.


It turns out it was working all the time, I hadn’t noticed I had given it the wrong output destination.  Nevertheless, I’m still getting the error and I still don’t know why it comes up.  Fortunately I can ignore the error.