Failed to Overwrite Web Layer

246
3
10-06-2021 10:13 AM
Labels (2)
KamillePreto
Occasional Contributor II

Hello all,

This is the first time that this error is happening. I am trying to overwrite an existing web layer in Enterprise (which I've done many times before). I am receiving a failed error, and I have no idea why. The log is pretty basic and doesn't really give me an idea of what's wrong, except that the publishing tool execution failed.

Does anyone have any ideas?

I just tested out re-publishing it, instead of overwriting, and it does the same thing.

Error_Overwrite.JPG

0 Kudos
3 Replies
jcarlson
MVP Notable Contributor

Have you made significant changes to the layer? Where does the data come from?

I have seen this error many times, but for different reasons (though the log just gives the generic error in all cases).

Sometimes, it's publishing a query layer, and something is wrong in my SQL statement. Sometimes there is an issue in one of the fields, or a particular invalid attribute somewhere.

But I've also seen this error for tile layers, and it had nothing to do with the data, but rather something with the local cache.

Can you attempt publishing the layer from another machine? Do you have administrative access to the Server? You might check to see if the uploaded data is still hanging out in the Server's jobs and needs to be manually cleared.

- Josh Carlson
Kendall County GIS
0 Kudos
KamillePreto
Occasional Contributor II

Hi Josh,

I did make significant changes to the data - attributes and geometry, which is why I need to overwrite it. The data has not been modified before. The shapefile is stored on our local server.

I did only add one field, which is a basic "roadname" field, nothing fancy. No queries or anything like that.

We do not have another machine here with ArcGIS Pro, I am the only GIS person here, so unfortunately I cannot test that. Yes, I do have administrative access. I selected "Service: System/PublishingTools" under Jobs and there is nothing listed. But when I select "Service: System/PublishingToolsEx", there are two succeeded entries from about 5 minutes ago. So I'm not sure it is related to the overwrite attempts.

0 Kudos
KamillePreto
Occasional Contributor II

I also just had our IT Dept restart our GIS Servers. It's back up now, so I tried again and it is still not working. I opened up the Server Manager logs and this is what is showing.

ServerLogs.JPG

0 Kudos