Failed to load system tools ... class not registered

225
2
04-03-2020 09:30 AM
Highlighted
New Contributor

When I attempt to open a project in ArcGIS Pro 2.5.0, I receive the message "Failed to load system tools e:\Resources\ArcToolbox\Toolboxes\IntelligenceTools.pyt Class not registered" (screengrab attached). I am fairly new to ArcGIS, and I do not know how to address this problem. In case it is relevant, I saved ArcGIS Pro and projects on external hardrive. Any help would be greatly appreciated!

Reply
0 Kudos
2 Replies
Highlighted
MVP Esteemed Contributor
Highlighted
New Contributor III

I am also having this issue (ArcGIS Pro 2.5.0):

I have tried:

  • renaming/removing .pyt files in that directory to no avail (as directed by another help thread)
  • uninstalling/reinstalling and also repairing the ArcGIS pro installation to no avail

This could be a coincidence, but I recently received a new PC from my organisation's IT dept. At first, I was unable to install ArcGIS pro on the new PC. 

I suspect the cause to be my 'roaming' Windows profile, persisted some component of my previous ArcGIS Pro installation - so when the installation was attempted on on the new PC, it tried to find the original directory/installation files for Pro (which are stored with my Windows profile). This is not possible because the files are on my old PC. I couldn't uninstall Pro either, using the windows 'remove/uninstall a program'.

Using this Microsoft tool seemed to clear this up, allowing me to reinstall what I thought/think is a fresh install of Pro (2.5.0).

However now I am discovering that I get the 'Class not registered' error upon startup of Pro. I also can no longer complete basic Geoprocessing/toolbox tasks - e.g. export feature class to geodatabase. The module runs 'successfully' in a few seconds, but there is no result. And considering the size of my dataset, taking 5 seconds for completion means something is definitely not right.

I suspect I have a corrupted registry on this new PC, due to all my troubleshooting trying to get Pro to install. Perhaps a registry cleaner or complete windows refresh will clean things up.

I am going to try download and install an older version of Pro. I will report back if this fixes things.

Edit

Just editing to say that downgrading to 2.4 did not fix the issue.

I have been diving deeper on this issue, I found a relevant comment on this thread:

There are multiple things going on here.

Natalie Robbins correctly identified she had a custom Python toolbox in the system toolbox directory, and that ENVI toolbox likely didn't have the correct libraries to work with the updated ArcGIS Pro 2.5 Python environment. Installing 3rd party toolboxes into your system toolbox directory can have these negative effects when moving between Pro versions. 

 

William Mayr had you previously cloned and made a custom Python environment? Environments need to be repaired or re-cloned when updating versions of ArcGIS Pro. The Intelligence Tools PYT toolbox is not the problem, that just happens to be the first Python functionality that the application is trying to load, as the system loads all the system toolboxes alphabetically (that is alphabetically the first toolbox in the system toolbox directory built with Python). Removing that PYT will just make the next one in the system toolbox directory fail. You have an underlying Python environment problem that must be remedied to proceed. You may want to contact tech support if none of this Python environment stuff that I mentioned applies to you.

This lead me down a path of uninstalling (or removing?) old Python installations - again I assume these are persisted across my Windows profile, as I have yet to manually install Python on my new PC.

I then re-downloaded and installed the latest version of Python (3.8.xxx something) and reinstalled ArcGIS Pro. Still no luck.

Then I found another thread here.

Reading these comments gives me some clues as to issues with Environment Variable PATH settings;

Based off your comment "I had ArcGIS Pro 1.4 installed to C:\ArcGISPro because it gave me an option of where I wanted to install it." In the other thread, and seeing the line conda.CondaError: Unable to determine if prefix 'C:\ArcGISPro\bin\Python' is writable I think your registry is still pointing to the 1.4 install. We use the paths set in the registry for some of the bootstrapping our envs need to do to avoid PATH collisions. Are you able to run regedit or is that not possible on this machine?  

Another user, having experienced similar issues to me (having previous Arc Pro installs present) writes:

ArcGIS Pro 1.4 was installed to C:\ArcGISPro.

 

ArcGIS Pro 2.0 was installed to my local profile.  The two installs never talked.

 

The old version of ArcGIS Pro left behind a number of registry entries for python root pointing to C:\ArcGISPro.

 

Once I uninstalled the old version of ArcGIS Pro in a separate action, it cleaned up the registry and now I have python access within ArcGIS Pro 2.0.

As a final comment,

Make sure you are aware of whether you are installing Pro for 'all users' or just you.  In the all users option, Pro is installed in a different folder (Program Files I think)... If 'just you' you have full control as to whether it can be installed... no registry problems result.

I never took much notice when installing Arc Pro, choosing 'for all users' or 'just you' made any difference. Anyway, I chose 'just you' this time, and now the error looks like this:

Sigh.... However now at least I can perform basic geoprocessing, which I couldn't do before. Still frustrating that it is still present.

Another thing to check is whether or not you can load the Python command line in Arc Pro:

I was getting 'failed to initialise Python' or something similar before. Now it works as expected:

I am still at a loss as to how to fully resolve this issue.

The there is some mixup between registry keys/files, python interpreter/core installations and arcGIS pro itself. Any help is appreciated here.

Reply
0 Kudos