export map problems

2773
9
01-16-2019 07:43 AM
CindyDeOms
New Contributor

I want to export a map exactly how it appears in the map view.  When I print or export, it cuts off the sides of the map.  How do I get the full image?  I can use an external tool to capture it but the resolution isn't as good as I would like. 

Tags (1)
0 Kudos
9 Replies
MarisaClaggett
Occasional Contributor II

Hi Cindy,

What export format are you using?  Are you just using the Share tab > Export Group > Map workflow?  Do you have an image of what your export looks like?

Best,

Marisa

0 Kudos
TimothyBarnes
Occasional Contributor

I believe this is a bug.

I'm using Pro 2.2.0 and exporting a map (not layout) to a TIFF,JPEG, BMP, PDF etc results in a square output even though the display/screen is landscape; the extent is zoomed and centered rather than simply being clipped to either the X or Y extent; brightness/contrast/gamma of raster layers isn't maintained and is set to default values.

So....lots is wrong there and it's pretty basic functionality.

0 Kudos
EdwinKeizer
New Contributor

I am having the same problem and am surprised that there is no answer to this yet. @ESRI #ESRI can you have a look into this asap? Or is anyone else from this community able to help out.

Thanks

Edwin

0 Kudos
KoryKramer
Community Moderator

Make sure you're updated to ArcGIS Pro 2.3 (plus patch 3) = 2.3.3

At 2.3, the export map issue was fixed.  See https://community.esri.com/community/arcgis-ideas/blog/2019/01/17/ideas-in-arcgis-pro-23 at 20 sec in the video.

See this thread for more details: https://community.esri.com/ideas/15804-printing-from-arcgis-pro  The export issue should be all set in 2.3.  The direct print part is still work that needs to be done (but since export works, you can export then print).

Hope this helps.

0 Kudos
EdwinKeizer
New Contributor

Thank you Kory,

Yes I have the patch installed. If I can still detail a bit further. When I create a layout and have this layout activated, I export to tiff  and am able to add a world file. Though then I get a square result cutting of parts of the map. When I export the layout closed to tiff, I get the map in the right dimensions but in this way it does not allow me to add the world file. 

Maybe this is the part that is still under development. Maybe you have some more info?

Cheers

Edwin

0 Kudos
danashney
New Contributor III

Looks like more export (pdf, jpeg, png, others?) issues at 2.7. I've had multiple users verify that the export, although "successful", drops elements of the layout. 

0 Kudos
AlexSlack
New Contributor

Yes, I am having the same problematic situation and the only deviation I see from people is when they select the feature of the file type, an abbreviation comes up next to it. I am going to **bleep** rage at this frustration 

0 Kudos
danashney
New Contributor III

Posted this at https://community.esri.com/t5/arcgis-pro-questions/arcpro-2-6-export-pdf-issue/m-p/1021991#M36681. Figure it should be here too:

FYI - received this from ESRI 1/22/2021. No ETA on fix but at least we know that they know. One key takeaway from the suggested workarounds - export to PDF (and other types) work in arcpy, so one solution is to script your export as its only currently broken when you go through UI.

"I’m sorry you are having trouble exporting your layouts. Esri is aware of an issue with exporting lines on a layout in ArcGIS Pro 2.7. This is a top priority issue being actively investigated, and a fix should be available in an upcoming service pack release. You can track the bug here: https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDEzNjM2NA==. This related GeoNet thread has some workarounds people have used to export their layouts while awaiting a fix: https://community.esri.com/t5/arcgis-pro-questions/exported-map-missing-lines-version-pro-v2-7/td-p/....

If you think you have a different bug, I encourage you to reach out to our Support Service Analysts. They have the tools and training to diagnose your issue and either provide an immediate fix or send the issue to the development team as a bug. You can reach our Support Services department at 1-888-377-4575, Monday–Friday, 5:00 a.m.–5:00 p.m. PST, or http://support.esri.com/contact-tech-support."

KoryKramer
Community Moderator

It looks like the initial question is from 2 years ago, and the recent posts are directly related to ArcGIS Pro 2.7.  There were some known issues with layouts at 2.7 that were addressed in Patch 1.  Please see the release notes and update to patch 1 if possible: https://pro.arcgis.com/en/pro-app/latest/get-started/release-notes.htm

Hope this helps.

0 Kudos