Errors in installation of Data Loading Tools in Utility Network Arcgis pro 3

672
3
06-26-2022 07:31 AM
RomuldKiobya
New Contributor III

UnsatisfiableError: The following specifications were found

to be incompatible with the existing python installation in your environment:

 

Specifications:

 

  - dltsolutions -> python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']

 

Your python: esri/win-64::python==3.9.11=3

 

If python is on the left-most side of the chain, that's the version you've asked for.

When python appears to the right, that indicates that the thing on the left is somehow

not available for the python version you are constrained to. Note that conda will not

change your python version to a different minor version unless you explicitly specify

that.

0 Kudos
3 Replies
DanPatterson
MVP Esteemed Contributor

maybe the package needs to be updated, it came out on the 23rd

Untools :: Anaconda.org


... sort of retired...
0 Kudos
KoryKramer
Esri Community Moderator

@RomuldKiobya are you working with this Data Loading Tools solution: https://solutions.arcgis.com/shared/help/data-loading/get-started/system-requirements.htm The system requirements list up to ArcGIS Pro 2.8. 

Please confirm and we can try to get this in front of the right team, but the solution may not have been upgraded yet to work with ArcGIS Pro 3.0...

WilliamKresan
New Contributor II

I've a similar issue I'm running into in the pursuit of migrating our Geometric network into Pro's Utility Network. I see that this may not have been rectified in 3.0 just yet but I'm hoping there might be some solution coming.

0 Kudos