Error with toolboxes in ArcGIS Pro 2.2

6260
24
Jump to solution
06-26-2018 05:28 PM
Highlighted
New Contributor II

I just upgraded to ArcGIS Pro 2.2.  When I open a new project and click on the 'Analysis' tab on the ribbon, I get an error message 'Failed to load system tools with a path to:  c:\program files\arcgis\pro\Resources

\ArcToolbox\Toolboxes\Spatial Statistics Tools .pyt

And no system toolboxes are loading by default (analysis, etc.).  Anyone know the fix?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
New Contributor III

work around: rename files with extensions .pyt to .pyt_xxx, close and open ArcGIS pro, the toolboxes are loaded

View solution in original post

24 Replies
Highlighted
MVP Esteemed Contributor

Not seen.  I suspect a repair of your installation might be in order

Reply
0 Kudos
Highlighted
Occasional Contributor II

This is concerning. I cancelled my update download as I read this.

Does it only happen in new projects? Or also with existing projects?

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

I have no problem with new or existing projects... I suspect your update didn't go well, that is what I was referring to.

Highlighted
New Contributor II

Hi Theodore:

New and existing.

mark

Reply
0 Kudos
Highlighted
MVP Regular Contributor

I saw that error message about the Spatial Statistics Tools toolbox popping by as well at one point when opening Pro. However, after another restart of Pro, this seems resolved and I can see the toolbox:

A more disconcerting issue for me though, is that I cannot seem to get the Conda managed Python environment to switch. At 2.2, the default Pro environment has become read-only according to the Help, and you are forced to create a clone or new environment to make changes and install packages. However, I for the life of me, cannot get this to work:

- As the Help stated, I cannot change or install a package to the default environment in 2.2

- Creating a Clone seems initially to work, but once I select the clone and close the dialog, I am left with an empty enviroment dialog:

- When I restart Pro, as the dialog warned me to do, the "test" environment I created and that IS visible in my user profile as a new folder, is not recognized by Pro:

So I am currently stuck with the default environment, that I cannot change because it is now read-only at 2.2...

Highlighted
Esri Frequent Contributor

Marco Boeringa‌ I have the same issue and opened a case with technical support. I will let you know the end results.

Glad it was not just me that had that issue.

--- George T.
Highlighted
Esri Frequent Contributor

I just got a response from technical support and they are aware of the issue, in relation to Python package manager, not the toolboxes.

My recommendation if for anyone encountering this issue to contact Esri Technical Support and get attached to the defect(s) that apply.

BUG-000112192 - Unable to activate a new Project Environment using the Python Package Manager

BUG-000111732 - Failed to activate a newly created Python environment in ArcGIS Pro

--- George T.
Highlighted
New Contributor III

I've experienced the same issues. uninstalled and re-installed doesn't fix the issue. I found all the tools available under installation folder C:\Program Files\ArcGIS\Pro\Resources\ArcToolBox\Toolboxes

Is there any fixes to this issue?

Highlighted
New Contributor III

This is the error message I got: 

seems like the Spatial Statistics Tools.pyt is corrupted

Reply
0 Kudos