Error with Iso Cluster Unsupervised Classification

08-06-2019 04:03 PM
by Anonymous User
Not applicable

I am writing a lab in which students will run Iso Cluster Unsupervised Classification on bands 1-4 of a Landsat image.

In the course of writing and rewriting the lab, I have used several different ArcGIS Pro projects to test the clarity and functionality of my instructions. In my first test project, I ran Iso Cluster Unspupervised Classification without issue using the 4 landsat bands.

However, when I ran through the same steps in the instructions with a different test project, I got the error: "Band ___ does not have valid statistics as required by the operation." All of the project settings, processing environments, and source data are identical between the two projects so I'm wondering how the tool could work in one but not the other.

Attempting to resolve the problem, I used the Batch Calculate Statistics tool on all 4 input bands, but got different errors when I tried classification:

ERROR 010112: The number of classes (0) is less than 1.
ERROR 010211: Could not open the specified point file c:\users\byron~1.sch\appdata\local\temp\arcgis~1\\sigtmp~1.gsg.

Again, everything works totally fine in the first project.

I opened a completely new blank project, didn't configure any processing environments or project options, connected to the source data, and also ran the classification successfully on the 4 bands, so I think this problem stems from something else about the way my project is set up that produces this error.

Any ideas about what might be behind this are greatly appreciated!



Tags (2)
0 Kudos
1 Reply
New Contributor

I am having the same error. Have you figured this out?

0 Kudos