Error Using Data Interoperability When Adding Reader in FME Workbench

940
3
01-25-2021 10:25 PM
BurtHardin
New Contributor III

I'm working in ArcGIS Pro 2.7, Windows 10 Home. I am running the Data Interoperability analysis tool Workbench. I get an error when adding a reader in the FME Workbench regardless of the file input or the Python Interpreter I choose. The error is as follows:

Starting translation...
FME 2020.2.0.0 (20201027 - Build 20787 - WIN64)
Data Interoperability (node locked-crc)
Permanent License.
Machine host name is: ***
Operating System: Microsoft Windows 10 64-bit (Build 19041)
Copyright (c) 1994 - 2020, Safe Software Inc.
Safe Software Inc.
FME initialized 'Esri ArcGIS Python 3.7', but the workspace Python compatibility setting is 'ArcGISDesktop'. Please check the Python compatibility setting in the workspace
Workspace requiring ArcGISDesktop is requested to run on an FME Engine configured to use a Esri ArcGIS Python 3.7 interpreter. FME cannot continue given the Python version mismatch
A fatal error has occurred. Check the logfile above for details
Program Terminating
Translation FAILED.
Workspace generation failed. Parameter file was C:\*\*\AppData\Local\Temp\ArcGISProTemp1044\FME_1611611330791_9172.

I have tried all of the Preferred Python Interpreters, but get the same error message.  It seems as though I need to change the "compatibility setting", but I'm not getting anywhere with that in my searches. Any suggestions? 

3 Replies
MichaelLoconte
New Contributor III

Same issue happening to me--it has been a few months since I last used the workbench and the first time with this error. Same error and versions as @BurtHardin.

0 Kudos
MichaelLoconte
New Contributor III

I never have looked here before as a casual user of the software. But I think I was messing with the wrong options, should have been looking at the scripting tool parameters. Toggling this setting to match my workbench options page seems to do the trick, screenshot attached.

BurtHardin
New Contributor III

Thanks for the response. I ran out of patience and time, so I went for the fme app. If I ever come back to this I will give your technique a try. 

0 Kudos