Select to view content in your preferred language

ERROR 999999: Spatial Join Failed

755
3
10-04-2023 05:55 AM
Lars_H
by
New Contributor II

Hey everyone, 

I get this error whenever I do a Spatial Join with my feature class "UWWTPS_DE_UK_wData_29_09_23". I want to join it with itself, so I get every combination of a plant and all the other plants within a 50 kilometer radius of it. I should then get a JOIN_FID with which I can calculate the amount of sewage slude within the 50 kilomter radius (Summary Statistics). 
The thing is, a colleague of mine tried it on his computer and it worked just fine. So I'm very confused why it doesn't want to work on mine. 
Maybe you have experienced something similar and may help me?

Thank you in advance for your answers.

Beste regards
Lars

Error Spatial Join.PNG

 

0 Kudos
3 Replies
ZakBaron
New Contributor III

Hi Lars, 

I did a quick test with some point data in ArcGIS Pro. I did not get the error message you show, but I also did not get a join. But after adding the data I wanted to join to the map twice and renaming one of them, the spatial join worked the way I expected it to. Note the join_count in the table. I think that might get you what you are after.

Zak--

0 Kudos
Lars_H
by
New Contributor II

Hey Zak, 

Sadly, it doesn't work that way either. I get the same error. But thank you for your fast response. I appreciate it! 

Best regards
Lars

0 Kudos
Lars_H
by
New Contributor II

I have an update on this problem. 

Surprisingly, the spatial join works when I reduce the number of fields involved. However, I don't understand why it worked on my colleague's computer. I monitored the performance of my computer during the aborted spatial joins and it was far from fully utilised. I can therefore continue my work, but I'm still not satisfied. So if anyone has a solution to the problem, so that I can join all the fields, feel free to write.

Lars

0 Kudos