Error 160231: Geodatabase System Tables not found.

800
3
03-02-2021 04:08 PM
Labels (1)
ChristalHigdon_USFS
New Contributor III

I am using ArcPro v2.7.1 and tried CalculateField on a hosted feature layer which I created and is in my AGOL content. I added it to ArcPro and then tried to Calculate Field on a null column.

Start Time: Tuesday, March 2, 2021 11:38:15 AM
ERROR 160231: Geodatabase System Tables not found
Failed to execute (CalculateField).
Failed at Tuesday, March 2, 2021 2:11:10 PM (Elapsed Time: 2 hours 32 minutes 54 seconds)
 
Upon looking up the error, I see:

160231: Geodatabase System Tables not found.

ArcGIS Pro 2.7 | Other versions

Description

No geodatabase system tables were found.

Solution

Note:

There is no documented solution at this time.

It calculated 22,404 records out of 71,282 total in the hosted feature layer, before erroring out.

Has this happened to anyone else? Does anyone know if this is a known bug?

0 Kudos
3 Replies
jcarlson
MVP Frequent Contributor

What was the calculation being done? I have had a field calculation fail partway through for a variety of reasons, but it's hard to say without knowing what your data looks like and what you're doing with it.

- Josh Carlson
Kendall County GIS
0 Kudos
ChristalHigdon_USFS
New Contributor III

For the test that failed a third of the way through, it was a simple 'Test'...


PARAMETERS:
Input Table: TongassNFWaterXing_COPY
Field Name (Existing or New): FishPresence
Expression: 'Test'
Expression Type: ARCADE
Code Block
Updated Input Table: TongassNFWaterXing_COPY
Field Type: TEXT


FIELD PROPERTIES:

Field Name: FishPresence
Alias: Fish Presence
Data Type: Text
Allow Null: True
Length: 100


Perhaps some sort of memory leak? But I would think 70K records would not be too big to handle... we have layers with far more features than this point layer and this was a simple text expression.

kmsmikrud
Occasional Contributor III

Hi @ChristalHigdon_USFS ,

I wish I had a solution to share or explanation, but I am also commonly getting the ERROR 160231 error in python scripts and also now just running the cell within an ArcGIS Pro Notebook. In the table I have there is only ~1000 records. It is very frustrating though as these scripts are commonly getting errors like "Internal server error. (status code 500) and other 5xx errors that I need to try and catch so the scripts can actually complete what I've tried to set up.

Are other folks commonly getting the status code 5xx errors as well? I get these commonly on the office network in addition to at home.

Thanks,

Kathy