ERROR 001249: Cannot package result

857
9
07-08-2022 10:01 AM
VerleyAltamirano
New Contributor II

Hey everybody,

I am having problems with the publication of a geoprocessing service, no error appears when performing the analysis but the tool shows me the following detail:

StatusMessage: Using ArcGIS Version 12.8 for staging (Source for version: GP Staging Parameters)
ErrorMessage: Consolidation failed
ErrorMessage: ERROR 001249: Cannot package result

I can't find any documentation about it. I appreciate your help.

9 Replies
BrianWilson
Occasional Contributor II

My first time out, I am publishing a model that does almost nothing (just runs "buffer"), which of course runs fine in Pro, then I get the same message. ERROR 001249

Here there be dragons. We have reach the edges of the map. I wish there was training or useful documentation on how to publish geoprocessing services. 

I try to do things The Way Esri Meant It To Be, but often it's very hard because of the cryptic error messages like there were "errors in the result". I get that, it tried to run the tool or validate it, but it validates and runs fine in Pro, so there is nothing left for me to do. HEEEEELLLO we need more detail than that?? So, it's doing something else besides just RUN and check output. WHAT? UNDOCUMENTED. 

I am going to sweep through training.esri.com one more time to make sure I did not miss something yesterday. Then I will try the Big Internet Search. In the end I will probably try to use Deep Note again, it seems more promising at this point.

Someone from Esri will chime in with advice about buffering here, I guarantee it. I don't care about buffering. I am just trying to create a geoprocessing service to test the server. If it worked then I would try to publish a tool written in Python, so that I could do actual work.

 

ChrisBeaudette
Occasional Contributor

I'm getting the same error as the OP:

 

2022-11-08 20:50:57	Status: InProgress	StatusMessage: Preparing data references and staging web tool	
2022-11-08 20:50:59	Status: InProgress	StatusMessage: Using ArcGIS Version 12.9 for staging (Source for version: GP Staging Parameters)	
2022-11-08 20:50:59	Status: InProgress	StatusMessage: Stage Tool initialized	
2022-11-08 20:50:59	Status: InProgress	StatusMessage: Consolidate data	
2022-11-08 20:51:00	Status: InProgress	StatusMessage: Staging GP service	
2022-11-08 20:51:50	Status: Failed	ErrorMessage: Consolidation failed	
2022-11-08 20:51:50	Status: Failed	ErrorMessage: ERROR 001249: Cannot package result Export Opportunity because of errors in the result.	
2022-11-08 20:51:50	Status: Failed	ErrorMessage: Failed to execute (StageService).	
2022-11-08 20:51:52	Status: Failed	ErrorMessage: Staging failed	

 

 

The tool passes validation and actually published successfully to another environment, but is failing in this one.

ArcGIS Pro v3.0, ArcGIS Enterprise/Server v10.9.1.

 

JonasNeubürger
New Contributor II

Getting the same error as @ChrisBeaudette, trying to upload a custom toolbox that combines various arcpy functions (including the standard buffer tool). Running it in ArcGIS Pro 3.0 works perfectly, but publishing it just won't work.

Is this because of some incompatabilty of ArcGIS Enterprise (and Portal/Server 10.9.1) and ArcGIS Pro 3.0?

Downgrading and trying from 2.9 now...

EDIT: Tried ArcGIS Pro 2.9, Tool runs fine - but I am still not able to publish it.

0 Kudos
Jay_Gregory
Regular Contributor

Anyone figure out solutions to this: getting same errors with Pro 3.0 and Enterprise 10.9 and 10.9.1.

0 Kudos
ChrisBeaudette
Occasional Contributor

I got the error when overwriting a published GP task.  Deleting the existing task and republishing it as new worked for me.  I'm using the same Pro and Enterprise version that you are:  Pro v3.x and Enterprise 10.9.1.

0 Kudos
Jay_Gregory
Regular Contributor

Hmm- I couldn't even publish one gp service.  I'll probably open a case. 

0 Kudos
DarinaTchountcheva
Occasional Contributor II

Same issue. Tool runs fine and displays results on the map. Can't publish to the server.

ArcGIS Pro 3.0.3, ArcGIS Server 10.9.1

Getting these very well defined errors:

"Status: Failed ErrorMessage: Consolidation failed... Status: Failed ErrorMessage: ERROR 999999: Something unexpected caused the tool to fail... Status: Failed ErrorMessage: Failed to execute (StageService)... Status: Failed ErrorMessage: Staging failed"

The same tool publishes just fine if I use ArcGIS Pro 2.9.5 and the same 10.9.1 ArcGIS server. 

Frustrating!

Tried all recommendations for this error by changing staging folder path to a shorter one. Changed tool name to a shorter one. Nothing works. 

Jay_Gregory
Regular Contributor

I was told by Esri support this is a bug with ArcGIS Pro at 3.03 (and possibly others), and will be fixed at the next version, releasing around the end of the month. 

https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDE1MDAzMA==

 

0 Kudos
DarinaTchountcheva
Occasional Contributor II

Thank you, Jay! That explains it!

I was just about to open a ticket. 

It has been a little hectic the last couple of months with the ArcGIS Pro versions. 

Moved from 2.9.4 to 2.9.5 to fix the symbology crashing error. 

Tested and prepared everything to move to 3.0.3 because of 2.9.5 crashing when accessing data through an OLE DB connection.

Now 3.0.3 is not the solution either because I can't publish a geoprocessing tool. 

I have installed a different ArcGIS Pro version on just about every dev machine I have available, so I can keep working.

Just venting. 🙂

0 Kudos