Select to view content in your preferred language

Environment fails to solve installing additional packages with Pro 3.1

498
0
05-01-2023 08:25 AM
Labels (1)
MiraAnand
New Contributor

I am trying to install the geospatial package using Anaconda in an environment with the latest ArcPy. I was able to set up my environment without a problem in 3.0. In earlier versions of Pro, I was able to install this package and then use it after downgrading fiona (following advice in this post).

In 3.0, I ran the following commands in Anaconda, which worked with no problems:

conda install -c esri arcpy
conda install geopandas
conda install geospatial -c conda-forge

When I upgraded to 3.1 I was not able to upgrade the environment in ArcGIS directly. I then tried to create a fresh environment with Anaconda (using the above steps) and the last step failed with initial solve, flexible solve, etc.

Eventually I downgraded back to Pro 3.0, which is working fine, but I would like to eventually upgrade to 3.1 if possible. Has anyone else encountered a similar issue trying to install additional packages with Pro 3.1?

0 Replies