Distance and Direction not Displaying Lines

04-28-2022 05:43 AM
New Contributor III

I am using ArcGIS Pro 2.9.2 on a Windows 11 Dell desktop.

I am having trouble with the Distance and Direction tool. Specifically, the "Line" drawing for Distance and Direction does not create a line using the point-to-point creation tool. After I place the second point, it spins for a moment as if processing, then nothing appears on the map, but the Distance and Direction option to "Delete Lines" becomes enabled as if there is now data on my map that can be deleted. I have also been trying this on a Windows 10 machine on the same version of ArcGIS Pro and I get the same issue.

Something that may help is that I am noticing the "Line" creation tool is not generating a feature class when I place the second point. If I do a circle, ellipsis, or ring, it will create the feature class, but the line will still not display or show up in the attributes table. 

I'd share images, but I don't know if any would be helpful as nothing is displaying or getting created when I use the tool. Any help would be greatly appreciated.

2 Replies
Esri Notable Contributor

I am using ArcGIS Pro 2.9.2 as well and tested the Distance and Direction tool on my data (screen grab below).  I used the Map Point tool for the Starting Point with point snapping enabled (left most point) and snapped to the 2nd point (right most in the screen grab below).  ArcGIS Pro generated a group layer (lines, range rings, ellipses and circles) and added it the Contents Pane.  The process ran for 2-3 seconds and labeled the output.  Some things to check, is the folder that the project fGDG "read-only"?  If so, change it's properties to read/write.  A second thing to try is rename the ESRI folder in your C:\Users\<user_profile>\AppData\Local and C:\Users\<user_profile>\AppData\Roaming to ESRI_OLD.  Sometimes this fixes the strange issues (like this) seen from time to time.

New Contributor III

Thank you for your reply. That didn't seem to resolve the issue. I tried this on both the Windows 10 and the Windows 11 machines. It will create the group layer for the polygons, but not for the line. Any other thoughts on this?

0 Kudos