Select to view content in your preferred language

Display Scaling causes context menus and windows to malfunction

350
2
Jump to solution
05-15-2024 04:22 PM
CayerA
by
New Contributor II

When using a scaled display (natively, not the ArcGIS Pro setting), I experience issues with certain UI elements. It appears to be any "floating" element, such as context/drop-down menus (any right-clicks, hamburger buttons, expanded tool galleries in the ribbon, or the ribbon itself if auto-hide is on) and any floating windows (such as Calc Field, Select by Attributes).

When mousing over any of these elements, every part of it disappears other than what the cursor is hovering over. Sometimes I can still click the option I want and have it work, but if it is a longer menu, clicking only results in the thing that is underneath it being clicked. I've attached a couple of screenshots, but it's difficult to capture the behavior, so hopefully I've explained it well enough - and now that I'm trying it, the floating windows are fine in this setting, unlike through the remote connection, so I will have to add a screenshot of that from home, if necessary.

I thought this was a remote desktop connection graphics driver mismatch issue, but I just experienced this while in the office on the physical machine. I recently replaced my second office monitor so that they are now both the same model (see below). When displayed at 100%, I can fit so much more on screen, but it's more difficult to read as a result, so I scale it up to 125%. When I changed the setting to 125 is when this issue started happening on the office computer as well. Previously, I had only experienced it while remoting in if I tried using Pro on my laptop screen instead of the external second monitor I have set up (where it works fine).

Office displays: Dell P2415Q x2, extended, 59.997 Hz, 3840 x 2160, 8-bit, RGB, SDR

Display adapter: NVIDIA RTX A4000 (driver v.31.0.15.28886

ArcGIS Pro 3.1.4 (this was also happening on 2.9.5)

Windows 10 Enterprise

0 Kudos
1 Solution

Accepted Solutions
CayerA
by
New Contributor II

Well, I believe I've found the issue here: FAQ: Why Do ArcGIS pro Pop-up Texts Appear Small? (esri.com)

While it's a solve to an unrelated issue, it seems to fix what I'm experiencing.

View solution in original post

0 Kudos
2 Replies
CayerA
by
New Contributor II

Here is another example of the glitchy-ness. This is from using the Explore function. Anything clicked when using that setting will result in a pop up panel with an empty attributes section that instead displays on top of the center frame of the UI. All it does it float there and block visibility of the data being displayed underneath, but you can't interact with it by clicking on the floating area, however you can scroll through it by scrolling from the panel where it's supposed to be displayed. Clicking on the ghost of it will just select a new feature on the map.

glitchyPopup.png

0 Kudos
CayerA
by
New Contributor II

Well, I believe I've found the issue here: FAQ: Why Do ArcGIS pro Pop-up Texts Appear Small? (esri.com)

While it's a solve to an unrelated issue, it seems to fix what I'm experiencing.

0 Kudos