Deep Learning

572
4
06-11-2021 01:11 PM
SaeedehMadani
New Contributor

Hello,

My name is Saeedeh Madani a GIS student at SAIT, and currently working on a capstone project so as a part of a requirement we need to work with deep learning and for the Train Deep learning Model to work we have to download Deep Learning Libraries Installer for ArcGIS Pro 2.8, and as we have searched a lot we could only find  Deep Learning Libraries Installer for ArcGIS Pro 2.7. So, if it is possible, could you please help us as to how we can have access to it?

Thank you,

0 Kudos
4 Replies
DavidPike
MVP Frequent Contributor
0 Kudos
SaeedehMadani
New Contributor

Thanks for the link David

0 Kudos
Tim_McGinnes
Occasional Contributor III

The installer for deep learning in ArcGIS Pro 2.8 has not been released yet, however it can be installed manually.

First, you need to create a cloned Python environment, as the default one cannot be modified. In the ArcGIS Pro Settings, choose Python and click on the Manage Environments button.

Tim_McGinnes_0-1623538255200.png

Find the default arcgispro-py3 environment and click on the Clone icon.

Tim_McGinnes_1-1623538350795.png

You can choose a name and location for the environment, but I recommend you leave them as default. Click the clone button.

Tim_McGinnes_2-1623538434702.png

The installation will take a little while. When it is finished, click the radio button in the clone to activate it and click OK. As shown by the message you should restart ArcGIS Pro so it will use the cloned environment.

Tim_McGinnes_3-1623538595679.png

To install the deep learning packages you will need to use the command line. In the Windows start menu choose  ArcGIS - Python Command Prompt. Make sure the command prompt is using your cloned environment (at the left of the prompt). Type conda install -c esri deep-learning-essentials=2.8 and press enter. Conda will search for the packages to install or upgrade and show you a list - press y to proceed.

Tim_McGinnes_5-1623538978308.png

You should now have a working deep learning environment. However please note that I have come across some issues when using the GPU in 2.8 and am waiting for the 2.8.1 update which should resolve the issue:

ArcGIS Pro 2.8 - Deep Learning with GPU - Fatal authorization error 

SaeedehMadani
New Contributor

Many thanks for your help Tim.

0 Kudos