Select to view content in your preferred language

Data Projection / Transformation - Different position in Desktop vs Pro.

1206
3
08-22-2023 06:12 PM
Labels (1)
sgambrel_Bouldercounty
Occasional Contributor

Hi all,

I have two shapefiles that have a different spatial reference - one is State Plane and  one is NAD83.  The two layers geographically align in ArcMap 10.8.1 but do not line up in Pro 2.8.8 (or in ArcGIS Online based on the Pro Map).  Data is shifted roughly 6-12" throughout, so I suspect a projection or transformation issue.  

Another possibility is that the coordinate system is defined incorrectly for one of the layers - however I'm not sure I buy this since they align correctly in ArcMap.  Also one dataset is from FEMA (who I trust to get this right), and one is data from my own organization and in the same State Plane coordinate system that we use for nearly every layer we produce.

 

I have changed the projection of the map, reprojected each layer to the other's projection, and changed the map projection again and the two layers will not align in Pro...  though they remain aligned in ArcMap.  This map ideally "works" in Pro and needs to eventually live in ArcGIS Online  - and currently the misalignment persists in ArcGIS Online as well. 

What gives??  How do I fix this??


Here are some screenshots:

Layers in ArcMap 10.8.1 in their native coordinate systems - aligned.

sgambrel_Bouldercounty_0-1692752205311.jpeg

 

Layers in Pro 2.8.8 in their native coordinate systems  - misaligned

sgambrel_Bouldercounty_1-1692752253787.jpeg

Layers in Pro 2.8.8, with the NAD83 layer reprojected to State Plane - misaligned.

sgambrel_Bouldercounty_2-1692752614134.jpeg

 

Layers in Pro 2.8.8, with the State Plane layer reprojected to NAD83 - misaligned.

sgambrel_Bouldercounty_3-1692752722824.jpeg

As mentioned, I've changed the projection of the map back and forth in each of these trials and cannot find a way to get the data aligned.  Any thoughts?

Thanks,
Sean

 




3 Replies
sgambrel_Bouldercounty
Occasional Contributor

Anyone?

0 Kudos
MicZatorsky_AEC
Occasional Contributor III

Sometimes to get things to line up, in addition to setting the Map's Coordinate System, you also need to tell ArcGIS what transformation to use:
MicZatorsky_AEC_0-1692848977210.png

0 Kudos
sgambrel_Bouldercounty
Occasional Contributor

Thanks for the input - I had tried that with a few of the most likely transformations (but accidentally left that out of the post).  Went back this morning and tried every single transfortmation that seemed even vaguely relevant and still no luck.

I'm suspecting bad data at this point - but then WHY would it line up in Desktop???

 

0 Kudos