Select to view content in your preferred language

Creating tpk files in Pro 3.1

1740
10
05-02-2023 11:31 AM
Labels (1)
MarkHammond4
New Contributor

In Pro 2.95 I can successfully create a tpk file but when I try it in Pro 3.1 with the same input and settings it gives the error "001461: failed to package tiles". Any ideas why?

Tags (1)
0 Kudos
10 Replies
DanPatterson
MVP Esteemed Contributor

This didn't apply to your case?

001461: Failed to package tiles.—ArcGIS Pro | Documentation

Description
The cache geoprocessing tool failed to package tiles successfully.

Solution
Verify that the Target Cache Directory and the ArcGIS output directory has available disk space for the TILE PACKAGE.


... sort of retired...
0 Kudos
Robert_LeClair
Esri Notable Contributor

Interesting...in my review of internal support cases, a customer had a similar issue.  What they did to resolve the case was clip the raster first using the Clip Raster GP tool before packaging.  Then use your worlkflow again to create the *.tpk.  What is the result?

0 Kudos
by Anonymous User
Not applicable

I have a similar problem as the above user did, and I changed my target cache directory and clipped the image in question.  Neither solved my problem or changed the error message.  Any other solution ideas, or ways to troubleshoot?

 

0 Kudos
LarkinWalter
New Contributor

I am having a similar issue. 

I keep getting "001461: failed to package tiles" even though I have 2 Terabytes of storage available. 

amallen
New Contributor II

Same error and I'm doing a small test area at small scales. I'd be surprised if disk space is the issue.

mdumas_SILC
New Contributor

I also ran into this problem creating a tile package for a large raster. 001461 was my only error. After a lot of toying around (changing the output file location, clipping the raster, creating multiple packages, trying all manner of projections, changing the package type, tweaking every setting, crying), I finally had success after simply leaving the "Area of Interest" field in the tool blank. 

I don't know if that will help any of you but I thought I'd give my 2 cents.

Robert_LeClair
Esri Notable Contributor

Thank you for posting this.  This appears to be BUG-000163419 - "The error message, "ERROR 001461: Failed to package tiles" is returned if the 'Area of Interest' parameter is specified when using the Create Map Tile Package tool."  It's currently "under review" by the ArcGIS Pro Dev Team.

Merritt
New Contributor

I have also ran into this problem and applying the workaround BUG-000163419 for ArcGIS Pro (esri.com) the error still occurs, I have not put any "Area of Interest" or "Extent" and it still fails. I can create a Vector Tile Package with no issue using the same parameters. 

0 Kudos
Robert_LeClair
Esri Notable Contributor

@Merritt and @ThomasPe - one thing I saw on the internals related to this question is building raster pyramids seem to fix the issue that other users were experiencing.  I'd recommend trying this workflow and see if the error message returns.

0 Kudos