Select to view content in your preferred language

Creating Tile Layer from a Geotiff File

877
3
09-03-2023 06:28 PM
GYSK
by
New Contributor

Hello everyone. I want to link global warming data acquired from IPCC's interactive atlas to a dashboard in PowerBI. 

It is my first time using ArcGIS Pro and as someone who has no prior experience in this software I am having a hard time figuring out how things work.

For learning purposes I first downloaded a geotiff file of the african continent, showing the change of temperature (degree celsius) of the selected scenario and period. It looks something like this when drag and dropped into ArcGIS Pro. 

GYSK_0-1693790180162.png

I then tried to follow an online tutorial and ran geoprocessing "Manage Tile Cache". Input Data Source is the geotiff file above, while Area of Interest is a shape file of the African continent I found online. However, the progress of this proccess has been at 100% for a long time, and I wonder if I am doing this right. 

GYSK_2-1693790546842.png


Since I will ultimately be uploading the tile layer to ArcGIS online, and import it from ArcGIS for PowerBI, I assumed that files should not be that large. 

In the tutorial, after this step is done, the process export Tile Cache will be used to create a tile package (tpkx) file. 

I will be very grateful if I can receive help on this and ArcGIS for PowerBI. But currently the main problem I am facing is with ArcGIS Pro so I posted in the ArcGIS Pro Questions category.

Please forgive my bad English as I am not a native speaker.

0 Kudos
3 Replies
GYSK
by
New Contributor

P.S: The shape file, when drag and dropped on the map looks like this: 

GYSK_0-1693791084309.png

 

0 Kudos
GYSK
by
New Contributor

Update: after 1 hour of waiting for the Manage Tile Cache and another 1 hour for export tile cache, I managed to create a tile package that shows the following: 

GYSK_0-1693802168999.png


However, the values shown in the legend (max 255 min 0)are different than the values shown in the pre-processed Geotiff file (max 31.4988 min 2.78468). I am trying to figure out how to bring the old values back: 

GYSK_1-1693802234046.png

 

What are the steps needed for me to change the value of the legends to match the geotiff version of the file?


0 Kudos
MicZatorsky_AEC
Occasional Contributor III
Using ArcGIS Pro 3.1.2 I have tried multiple attempts at Create Map Tile Cache and all got stuck at 99%. The right amount of cache is created in the right folder during the time estimated, but it never sticks the landing. It just never finishes.

I tried removing all spaces from names and paths, moved everything to a local SSD, checked geometry errors, put on a magnetic bracelet and lit an aromatherapy candle. Still no joy. I wrote an arcpy script and didn't even open Pro, and it still failed to complete.

I checked out a licence, disconnected from my office VPN and on the next attempt, the Python script worked! This is now repeatable.  Both the ArcGIS Pro GUI and a script calling  arcpy.management.CreateMapTilePackage() succeed when the script is started with no access to the my work network. If ArcGIS Pro or the script starts with network access, it never completes.

I have no idea if it is related to accessing the licence server or some firewall rule. But if you are stuck too, try checking out a licence, pulling the blue cable and disconnecting from wifi. Strange but true.

When it does work, depending on your data volume and tile level, it can take a very long time.  Here are some stats for how long it took to turn my map into Map Tile Cache.  The x-axis is the tile package level, and the y-axis is generation time.  Going from Level 17 to Level 18 would more than double the processing time. 

MicZatorsky_AEC_0-1693868550198.png

 





0 Kudos