Copy-pasting table into Excel with correct columns

218
3
09-02-2021 12:38 PM
Labels (1)
AlfredBaldenweck
Occasional Contributor III

I have a quality of life question.

If I select rows in a table and press "Copy", then paste them into Excel, sometimes they will paste correctly as separate columns, but frequently they'll all paste into one column.

So for example, my nice table that should look like this

NameParcelAcreageLast updated
Smith, J.1012345.039/01/2021
Doe, J.9823522.108/31/2021
Stone, M.78723240.007/26/2021

 

is pasted as 

Name Parcel Acreage Last updated   
Smith, J.1012345.039/01/2021    
Doe, J. 9823522.108/31/2021   
Stone, M. 78723240.007/26/2021   

 

I haven't figured out if there's a pattern to it happening or not, but I'd like it to stop. It will happen on a dataset one day, then later in the day it'll work perfectly on the same set. 


Is there an easy way to get it to not concatenate into a single column like this?

Thanks!

0 Kudos
3 Replies
DanPatterson
MVP Esteemed Contributor

Your first nice table looks like every column is text given the left justification... or is that an artifact of the forum copy/paste


... sort of retired...
0 Kudos
AlfredBaldenweck
Occasional Contributor III

That's just because I made up this data to write the post. It's been happening with a mix of column types; Text and Numbers will both get squished like this.

 

I will also say that I've had this issue in Pro and in ArcMap in the past.

0 Kudos
DanPatterson
MVP Esteemed Contributor

Ahh... ok.  I usually use Table To Excel (Conversion)—ArcGIS Pro | Documentation

after making a selection in Pro or export to csv if using other applications.  

I have noticed flakey copy/paste in other applications also but usually when a cell is blank/ <null>


... sort of retired...
0 Kudos