Copy/paste features in ArcGIS Pro - how?

28771
34
Jump to solution
04-20-2015 08:48 AM
SaraKidd
Occasional Contributor

Trying to copy/paste selected features from one layer to another layer in ArcGIS Pro (file geodatabase). I have used Select by Attribute to grab the features of interest, click on Copy, then click Paste. It seems to be just making a copy of the whole layer. It did not copy the selected features and did not paste them into another layer. It seems there is supposed to be a "Paste special" option but that is not activated - only the regular paste. What am I missing? Thanks.

Tags (3)
1 Solution

Accepted Solutions
JenniferCadkin
Esri Contributor

After making the selection, please ensure the map with the selected features has focus, e.g. by clicking on the map view's tab.  The Edit tab will not enable copy/paste if the GP pane has focus.

View solution in original post

34 Replies
SepheFox
Frequent Contributor

Have you configured the application for editing: Introduction to desktop editing—ArcGIS Pro | ArcGIS for Professionals

0 Kudos
SaraKidd
Occasional Contributor

Sephe Fox, I did look around in the editing properties but didn't see anything that needs to be changed in order to be able to copy/paste individual features between layers. My layers are editable. Is there something specific I need to do? Thanks.

0 Kudos
JakeSkinner
Esri Esteemed Contributor

Hi Sara,

Try the following:

1.  Select your features > Edit tab > Copy

2.  Paste should become active.  Click the dropdown and you will see Paste Special:

screen1.png

3.  Click 'Paste Special' and another dialog will appear that will allow you to choose which feature class to paste the copied features to:

screen2.png

SaraKidd
Occasional Contributor

There seems to be an issue here depending on how you select the features.

The procedure you outlined above only works if I use the Select tool and manually select the features.

When I use the Select Layer by Attribute, all the cut/copy/paste icons are grayed out.

If I select features in the attribute table just by clicking on them, sometimes I get the cut/copy/paste icons to turn on and sometimes none of them do. But the "paste special" arrow is never active in this scenario.

Let me know if you need more info.

SamuelTompsett
Occasional Contributor II

Hi Sara,

After selecting the features in the attribute table, have you tried right clicking on the feature class, data, export features.

The Copy Features tool should maintain your attribute selection.

I tested this with Pro 1.0 and everything worked.

Hopefully that helps!

-Sam

SaraKidd
Occasional Contributor

Thanks Sam. I'm actually trying to copy/paste the features from one feature class into an existing feature class, not create a new one. This was straight forward in ArcMap: start editing, select, ctrl+C, ctrl+V and done.

This is what happens when I click on a feature to select it in the attribute table. The drop down arrow for paste special is grayed out. When I click Paste, it copies the whole layer, not the selected features.

pastespecial.JPG

It works fine selecting them with the Selection tool so I'm not sure why selecting features another way is not working.

JakeSkinner
Esri Esteemed Contributor

You may have discovered a bug.  I would recommend logging a tech support incident so that ESRI can confirm whether or not this is a bug, and to bring this to development's attention.

In the meantime, I would recommend using the Append tool as a workaround.

deleted-user-K9U1SzFzl3f7
New Contributor III

Yes, I also believe this is a bug. Currently using Pro 2.2.0 and I need to close arcpro and re-open the software to allow the paste button to actually appear solid and not greyed-out. It appears the copy paste function is only working between two tables - open any more than that, and a restart of pro is necessary.  

JenniferCadkin
Esri Contributor

After making the selection, please ensure the map with the selected features has focus, e.g. by clicking on the map view's tab.  The Edit tab will not enable copy/paste if the GP pane has focus.