Convert Time Field outputting date only

445
2
11-29-2018 02:15 PM
GabrielMarcus1
Occasional Contributor II

Using ArcGIS Pro 2.2.4. I'm converting a date time field of format yyyyMMddHHmm into the Date format. 

Why does the resultant output contain only dates and not times? 

I added some additional rows containing odd times "1402" "2223" and it does the same thing. 

The input files are from the Storm Prevention branch of the National Weather Service. www.spc.noaa.gov/products/outlook/day1otlk-shp.zip

 

I also added a field, ran a field calculation script to change the input to MM/dd/yyyy HHmm format and ran Convert TIme Field on the new field with the same results of dates being converted but not times. 

I viewed the help file but nothing mentions dropped time values. 

2 Replies
DanPatterson_Retired
MVP Esteemed Contributor

the only thing that would drop the time would be a shapefile output.

python is used for the conversions, can you post what you used for the calculations

GabrielMarcus1
Occasional Contributor II

Ahh. That's why the time was dropped. I was saving it as a SHP.  That should be included in the help file! Problem solved. 

Since you asked

Here's the python I used to manually convert the time to a text string to MM/dd/yyyy HHmm format that I ran the Convert Time on. 

def confD (V):
return V[4:6]+"/"+V[6:8] + "/" +V[:4] + " " + V[8:]

0 Kudos