Cannot Annotate Selected Features in versioning environment

242
1
01-30-2023 04:06 PM
MPiotrak
New Contributor

Hi,

I have problem using geoprocessing tool Annotate Selected Features while working on a version. To be brief:

  • I have two layers - one feature layer and another annotation layer that is related to the mentioned feature layer.
  • Both are versioned in the traditional way.
  • Using given tool on the default version is successful.
  • Proceeding by analogy on the child version, I get the following error: ERROR 999999: Something unexpected caused the tool to fail. Contact Esri Technical Support (http://esriurl.com/support) to Report a Bug, and refer to the error help for potential solutions or workarounds.
  • I'm working on ArcGIS Pro, version 2.9.2 - unfortunately this is a prerequisite for me.

I hope that someone has encountered a similar problem and has already found a solution.

Thank you in advance for your help,

Michał Piotrak  

0 Kudos
1 Reply
Robert_LeClair
Esri Notable Contributor

Michal - there is a non-reproducible BUG-000122343 - The Annotate Selected features tool fails to run in ArcGIS Pro when a feature class with linked annotation is registered as versioned.  It was noted that if you do not registered a feature dataset as versioned or you unversion it, it does run successfully.  It was seen if feature class and annotation are outside of a feature dataset as well.  It is similar to BUG-000120623 - unable to run the Convert Labels to Annotation tool on a versioned data in ArcGIS Pro when feature-linked annotation is selected.  This bug is no longer reproducible after ArcGIS Pro 2.7 but you're at ArcGIS Pro 2.9.2 so that's not it.  Not a great answer I know but it's what I've found.

0 Kudos