Can't login to ArcGIS Pro, login screen stays empty?

14700
40
Jump to solution
02-12-2020 01:53 AM
DanielHess
New Contributor

Hello,

i am not able to use ArcGIS Pro. It runs with a named user license, but i am not able to login to my account because the screen with the gui stays empty (see screenshot.).

Things i tried:

- Reinstall ArcGIS Pro, install updates manually, install different ArcGIS Pro Versions, Install/Deinstall Data Interop Center

- Use different default web browser

- Update Windows 10

- Multiple PC restarts

- uncheck "Sign me in automatically"

- Stop Antivir/Firewall

I don't have any further ideas what i could try... maybe someone could help?

Greetings and thanks

Daniel

Tags (3)
0 Kudos
40 Replies
ThreeTwoFour
New Contributor II

Thank you! This works for me so far. The cool thing is it is actually using Firefox to login now which is my default browser! It would be nice to know why this is happening though,

0 Kudos
Brian_Culpepper
New Contributor II

Thanks for this, and I tried dragging the "blank Sign-in" screen into another monitor (dual-monitors connected to a Lenovo Yoga laptop)... in the adjacent monitor(s) the ArcPro Sign-In screen was 'painted', yet not Active for entering a username/password for an ArcGIS.com managed user account.....  

However, the ArcPro splash screen that opened when I first opened ArcPro 2.7.2 still contained the 'active sections' of the ArcGIS username/password and 'sign-in' button...   If you move your mouse cursor SLOWLY over the ArcPro splash screen (original/opening location) you can locate the TEXT entry section to type your username and then password.... but you won't see any text changes over the ArcPro splash screen... just enter your username/password then move the cursor down a few cm and you'll notice the cursor change to the pointer/hand and left-click there.....if your username / password was entered without any typo's it'll work!! 

Has this REALLY been an issue since version 2.6?   we're at 2.7.2 now and the only permanent fix is to 'disable hardware acceleration' in the registry??  

Come on, man!!

UPDATED Hardware REPORT/REQUEST:   My Lenovo Yoga was built with: Intel(R) Iris(R) Xe Graphics  too...

MY SOLUTION:

the REGISTRY EDIT solution worked for me: Disabled HW Acceleration (Until a permanent fix from Intel)


DisableHWAcceleration.png
 

yunmeiHuang
New Contributor II

Thank you, Alexander. I'm glad that it works for you! As for me, I just bought a new laptop and got this problem. In the beginning, I was considering the issues with my laptop. I even exchange a new one with the seller. Now, I think these are some bugs of pro2.7. I used to install pro 2.5 on my old pc without any problems.

BTW, when I try to use the python 3 notebooks in the software, the notebooks also are so slow. When I try to type, the screen keeps grey. It takes serval minutes to display some words. I can't use the notebook to code(too slow!). This might be the same issue with the login pages.

0 Kudos
NileshValwaikar
New Contributor II

Hi,

Even i am facing the same issues from last 1 week, i am using ArcGIS Pro v2.7

I have tried all solutions given in this thread but no success yet.. I even tried by setting the IE security to LOW.

However in my case there is a Mix scenario of success and failure..

1) Arcgis.com Login - Success

2) If i enter the fully qualified system name with port - success

3) If i enter the fully qualified system name without port - Blank Screen

4) Enterprise Login - Blank Screen

Problem gets serious when even if i login using the system name when i do any publishing task it again prompts the sign in dialog and it appears blank. If i cancel this than the publishing finally gets failed and the logs has the following message "You are not signed in to ArcGIS Online." before logging the failure results.

Any help or guidance in this regards would be highly appreciated...

 

KimSvensson
New Contributor

Same problem here. Tested almost everthing above. 2.5 version works, so cleraly it is something with my hardware and newer versions of pro. 

Have Intel Iris Xe vga. 

AgostinoCirasa_sitr
New Contributor

There is a problem with WPF Hardware Acceleration and the Web Browser Component (CEFSharp) used by ArcGIS pro. The only way that I found to resolve this issue is to temporary disable WPF Acceleration https://docs.microsoft.com/en-us/dotnet/desktop/wpf/graphics-multimedia/graphics-rendering-registry-...

 

greenfld
New Contributor II

Suffering this problem with 2.7 which also affects the Explore tool, and whilst I can get that tool to display by resizing it, the scroll bars don't work and my screen isn't big enough to fit all the fields from some of my feature classes 

Thanks @yunmeiHuang for your solution to the log in screen. I wasn't able follow your process very well unfortunately, but found that by moving the mouse cursor up from the mid left bottom, I could identify the OK button, then the password and username fields by the shape of the cursor, then paste them in.

Thanks also to @AgostinoCirasa_sitr . I can confirm that your registry solution works, at least for the Explore tool. I haven't needed to log in again since. Though I'm not sure this is something your users should be required to do ESRI

I have since had two updates and now on 2.7.2, neither of which were to address this issue. Using 2.4.2 at work and this is not a problem.

Edit:

I wasn't keen on disabling hardware acceleration as I wasn't sure what the wider implications would be, so I wrote a python script to toggle the hardware acceleration off, start ArcGIS Pro, then wait a few seconds for it to read the registry, then toggle it back on. As the registry is only read at startup, it only affects ArcGIS.

Thereafter, all dialogs seem to be working (so far)

Edit: Updated to 2.8. No change to this issue

0 Kudos
Pessimistik
New Contributor

Same issue here. I 'solved' the problem by filling in the blank screen thanks to the login screengrab on page 2. 

The devs should be ashamed NGL

0 Kudos
JohnMoses2
New Contributor II

Looks like the issue has to do with hardware acceleration.

Ersi has a solution here: https://support.esri.com/en/Technical-Article/000025347

Tip, you'll have to do some registry edits to fix.

BertKraan1
Occasional Contributor III

I've had this in 2.8.3 right after IT had installed 2.8.3 in a Citrix environment. I didn't see anything suspicious but they could see this:

BertKraan1_0-1635247366512.png

After IT whiteflagged this .exe for execution I could sign in and start Pro.

 

+1 for IT ! (whoohoo)

0 Kudos