Can not disable Fully Qualified Field Names

138
4
12-28-2021 08:19 AM
Labels (1)
DanielBinghamd
New Contributor

I can't disable fully qualified field names.  In the ModelBuilder I have unchecked "Maintain fully qualified field names" in the Environments.  I've also made sure it's unchecked in each of the tool environments.  When I first build my models this was not an issue, then they just started appearing fully qualified.  

My models run several variations of data through the Optimized Hot Spot Analysis and Kernel Density tools.  

0 Kudos
4 Replies
DanPatterson
MVP Esteemed Contributor

Is there a chance that input fields from different datasets are causing this? or are you using the same input data with just variations of some of the parameters?


... sort of retired...
0 Kudos
DanielBinghamd
New Contributor

I use a singe dataset imported from a .xlsx file.  So I don't even have any joins.  The extra names all come from within the model.  

0 Kudos
DanPatterson
MVP Esteemed Contributor

So it isn't even a geodatabase table then? I can see no reason why a model would revert and environment parameter if a run completely terminates before restarting


... sort of retired...
0 Kudos
Robert_LeClair
Esri Frequent Contributor

There is a Python snippet that will disable fully qualified names - 

arcpy.env.qualifiedFieldNames = False

Not sure how you could add this to your model though.

0 Kudos