Select to view content in your preferred language

Calculate Geometry Error

1126
4
08-24-2023 04:38 AM
Labels (3)
sjet1010
New Contributor III

I created two fields for x, y coordinates. Every time I try to do a Calculate Geometry it errors out with no error number but it says, 

Traceback (most recent call last):
     File "c:\...\ArcToolbox\scripts\calculategeometry.py", line 290, in <module>
         CalculateGeometry(fc, properties, lUnit, aUnit, cs, cformat)
File "c:\...\ArcToolbox\scripts\calculategeometry.py", line 130, in CalculateGeometry
      ucur.updateRow(row) 

It has only done this so far with both my water and electric utility network databases, which can only be used via feature service. I ran a test on my other non-utility network layers that I access directly from the database and it works just fine. 

4 Replies
TrevisMartin
New Contributor III

What can you tell us about the feature service?  Is it editable, etc? The update cursor is failing which implies it doesn't have edit access to the service, or is being prevented by the feature service.  Are you making the x, y columns before the attempt to populate, or letting the tool create them?

0 Kudos
sjet1010
New Contributor III

I was trying it originally to my feature services that are part of a Utility Network, then I tested it on all my other editable layers that are not part of a Utility Network and still received the same error. I don't get the error when I try it with a layer directly from a database, but with layers that are part of a Utility Network you can only edit via feature service. The layers that I am pulling in are feature layers that have editable capabilities. I added the x y coordinate columns to the feature class. 

0 Kudos
kterry1983
New Contributor II

Did you have any luck with this? I just attempted to calculate eastings into a feature service saved in the portal and received the error. 

 

0 Kudos
kterry1983
New Contributor II

In my case, the error was caused by selecting the feature service using the drop down list in the tool. When I clicked on the folder icon and navigated to it in the portal, it worked. 

0 Kudos