Bug with dynamic text in map series with ArcGIS Pro

363
4
Jump to solution
01-10-2024 10:25 AM
QuébecSubaquatique
New Contributor II

Hello,

I'm making a map series in Arcgis Pro and I'm using dynamic texts. I have all the information, no field is empty in the database. It works for 90% of the map series, but there are a few that only shows a "0" instead of what I ask for: "name of sector (name of municipality)".

Does anyone knows why some of them are showing a 0 instead, and how to correct this so all of the maps show the correct information?

Thank you,

Sabrina

0 Kudos
1 Solution

Accepted Solutions
RonaldHaug
Occasional Contributor II

Hi QuebecSubaquatique!

That definitely is a () up there in the "not working" map series.

1) So you checked in the feature class attribute table there is writing in the Anse-de-Roche row under the attribute field "name of sector (name of municipality)" and Anse-de-Roche is in that particular map?

2) If yes, what happens if you replace the text in that field  with a simpler text string like "home sweet home"? There may be an unallowed character in the field.

3) In the ArcGIS Pro help for map series and dynamic text there is a mention of: Table dynamic text, Query, and Map series rows — Uses only the rows that intersect the current map series index feature. This option is only available for a spatial map series and does not apply to stand-alone tables. Check here:

https://pro.arcgis.com/en/pro-app/latest/help/layouts/add-dynamic-text.htm#ESRI_SECTION1_23EBDF119FC... 

Here's another help page for map series and dynamic text:

https://pro.arcgis.com/en/pro-app/latest/help/layouts/use-dynamic-text-with-map-series.htm

Hopefully you will dive right in and get to the bottom of this mystery. Let us know!

View solution in original post

4 Replies
RonaldHaug
Occasional Contributor II

Hello QuebecSubaquatique!

Would you please paste two snipping tool pictures to illustrate when the dynamic text works and when it does not.

That way you can show us how you are using the dynamic text.

Thank you!

0 Kudos
QuébecSubaquatique
New Contributor II

It is the light blue text on the top.Not workingNot workingWorkingWorking

0 Kudos
RonaldHaug
Occasional Contributor II

Hi QuebecSubaquatique!

That definitely is a () up there in the "not working" map series.

1) So you checked in the feature class attribute table there is writing in the Anse-de-Roche row under the attribute field "name of sector (name of municipality)" and Anse-de-Roche is in that particular map?

2) If yes, what happens if you replace the text in that field  with a simpler text string like "home sweet home"? There may be an unallowed character in the field.

3) In the ArcGIS Pro help for map series and dynamic text there is a mention of: Table dynamic text, Query, and Map series rows — Uses only the rows that intersect the current map series index feature. This option is only available for a spatial map series and does not apply to stand-alone tables. Check here:

https://pro.arcgis.com/en/pro-app/latest/help/layouts/add-dynamic-text.htm#ESRI_SECTION1_23EBDF119FC... 

Here's another help page for map series and dynamic text:

https://pro.arcgis.com/en/pro-app/latest/help/layouts/use-dynamic-text-with-map-series.htm

Hopefully you will dive right in and get to the bottom of this mystery. Let us know!

QuébecSubaquatique
New Contributor II

Thank you! It worked.

0 Kudos