Azure SQL Server Database Connection

169
1
03-22-2021 07:53 AM
Labels (3)
johndel85
New Contributor

I have read through many of the responses and haven't found anything that quite attacks when I am faced with - or I'm just not skilled enough to realize what I'm doing wrong and was hoping someone might have some knowledge to point me in the right direction for help. We recently moved our on-prem servers to the cloud using VM's in Azure off-prem. My GIS machine is in Azure along with our SQL server (on a separate machine). I can connect find from Pro to the database using server.domain.com,1433/instance but the Azure machine doesn't use the ,1433 port to connect so when I attempt to register the datastore connection it fails. I tried editing the SDE file manually to remove the ,1433 but that didn't work. I attempted to create an SDE file in python following the info here => Solved: python script using arcpy.CreateDatabaseConnection... - Esri Community and it didn't work either (couldn't connect to the server since I removed the ,1433 port). I can't install Pro on the GIS machine in Azure to make the connection there since our Azure machine is unable to connect to the on-prem licensing machine. Is there a way to manually make the connection file so that I can specify the SQL server connection without using the port information?

0 Kudos
1 Reply
Robert_LeClair
Esri Frequent Contributor

One workaround - can you install ArcGIS Pro on the Azure machine with a single use license and make the connection there?  Is that possible?

If not, I'd recommend contacting Esri Support Services at 888-377-4575 and start a case with them.  They will be able to assist you.

0 Kudos