ArcPro 2.7 FMV Crashing

02-22-2021 06:41 PM
Labels (1)
New Contributor III

Anyone use the Video Multiplexer tool in ArcGIS Pro 2.7 successfully? I've followed their tutorials and tried formatting my data exactly as they have. I've also tried formatting the data using what I've seen in several of the ESRI Community posts, but it crashes the program every time I try. I started by trying to make it work with csv files from Airdata and a Mavic 2 Pro (drone) video file. I thought maybe I wasn't understanding the way the csv files needed to be formatted, but then I flew the drone using SiteScan and tried using that data which is supposed to work seamlessly with FMV, but Pro 2.7 still crashes every time I try running the tool.  The most recent post I could find about this subject was version 2.2 and I'm not sure where to turn next. I've attached my metedata file in case anyone sees an obvious problem with the formatting.

0 Kudos
4 Replies
Esri Notable Contributor

Scott - I see you logged a case with Esri Support Services.  This is the best way to get an immediate response.  Let us know what you learned from the Support Analyst.

0 Kudos
New Contributor III
Thank you. So far, the representative from Support Services only asked me
to send the files associated with the crash report (video file, metadata
and field mapping file). I sent those files and am waiting for a response.
I also sent the error logs to another representative. I also requested a
FMV license to try testing in ArcGIS 10.8.1 and received that license file
from my customer service rep, but I haven't gotten that to work yet either.

0 Kudos
New Contributor III

This is the error message I got when trying with Desktop 10.8 (see attached image).

0 Kudos
Esri Regular Contributor

Scott - sorry for the frustration - I know one of our support fellows was helping with this but I took a look and I can give you some answers but possibly not complete at this stage.

1) Unfortunately your site is in a region of latitude where we found a killer bug, and the geographic transformations don't work properly.  Fortunately, this has been fixed in Pro 2.7.2 - could you download and install the new version?  

2) Your drone is reporting incorrect altitudes.  This is pretty common, and I'm unclear why it happens so much.  (Most) Drones report altitude as ellipsoidal height from GPS since they don't know where the ground is, nor sea level.  The terrain at your site shows ellipsoidal height of ~790 meters, but your metafile shows minimum altitudes ~690.  (I assume you weren't 100 meters underground).  See the attached - I've made a guess that the records showing 690 were when the drone landed, so I added 100 meters to your Z values. 

The attached file MIGHT work, but this Z error does not explain why something is crashing. 

3) can you clarify what is crashing?  Here you say the  Video Multiplexer tool, but your post on the webinar page said "ArcGIS FMV is crashing".  Is it the whole program, crashing when you load the multiplexed video?  or is the tool crashing and you're not getting an output video file?   I tried your metafile with my own video, and it worked except for showing the drone underground.  When I added 100 meters, it worked to bring the drone above ground and nothing is crashing.  

It's possible your crashing problem is due to an additional conflict somewhere - but could you try my modified metadata file?

4)  I try not to "pass the buck" but it could be something in your video file.  If it still crashes with my metafile, could you try downloading this video file and using it in the multiplexer?

If it works, then that would point to something wrong in your video file.  

Hoping this helps - let us know.

Cody Benkelman 

0 Kudos