ARCGIS pro tools are not working

11-04-2021 08:53 AM
New Contributor


I tried to update the ArcGIS pro as received the notification of the update. It wasn't upgraded and revert back due to some error in it. Later on, I reinstall my old files of ArcGIS Pro but now no tool is working as showing the tools are not authorized. I tried to enter the authorization number which I have but it is also not accepting it. 

Previously, all tools were working. Can anyone help me with how it will work again? My licensed version is totally useless for me

0 Kudos
2 Replies
MVP Esteemed Contributor

What version of ArcGIS Pro are you using?

How is ArcGIS Pro licensed (Named User, Single Use or Concurrent Use)? If Named User, did you authorize ArcGIS Pro to work offline?

As you respond to the above queries, I would also suggest you to contact Esri Support.


Think Location
Regular Contributor

Another thing, depending on what exact error message you're getting, is to check any add-ons you have. I know that, for example, XTools 20 removed the ability to use any tool in Pro 2.7 that wasn't also available on AGOL due to compatibility issues. ("Failed to load system tools").

0 Kudos