ArcGIS Pro "Summarize Within" Geoprocessing Tool Giving Incorrect Results

441
2
06-06-2019 06:41 PM
MitchHolley1
MVP Regular Contributor

I have run the "Summarize Within" GP tool in ArcGIS Pro 2.3.3 and it seems to be giving incorrect results.  The input is a Parcel feature class with a definition query applied to only show one parcel.  The summary polygon feature class is representing a site that also has a definition query applied.  After running the "Add Geometry Attributes" GP tool, the [POLY_AREA] field reads '124999.66403816' (see image 1).  But, after running the "Summarize Within" tool, the summary area found in the result table reads '125018.31814394'.  Does anyone have any idea why?

1.) Before running "Summarize Within" with inputs

2.) Result table after "Summarize Within" tool is complete

2 Replies
RalfWessels
New Contributor II

Hi Mitch,
looks like you have a similar problem with the tool as I do.
In a test I found that calculating areas with "Add shape summary attributes" gives a different result than the "Summary Fields" > Sum "Shape_Area" method in the same tool.
The result with the method "Add shape summary attributes" (which you also used) is definitely wrong. Only with the method "Summary Fields" > Sum "Shape_Area" the correct result is output (see screenshot).
How can it be that when using Summarize Within 2 different results are output?
Are different calculation methods used here for the area calculation?
Is this a bug?

I use ArcGIS Pro version 2.8.3
The coordinate system used in the map and the polygons stored in a file geodatabase is UTM Zone 32N (EPSG:25832).

Best regards from Berlin
Ralf

Translated with www.DeepL.com/Translator (free version)

 

Screenshot summarize.jpg

KaraUtter1
New Contributor II

I am having this same issue. When I run the Summarize Within and add Shape Summary Attributes in acres, it's calculating about 500 acres off from the number that calculates when I run a Calculate Geometry for acres on the same shape. This is definitely a problem. I'm using a state plane projection in feet, so I this is not a GCS issue with converting degrees to other units, it's definitely a bug in the geoprocessing tool itself.

@JanCunningham