Select to view content in your preferred language

ArcGIS Pro Crashed when exporting to image

09-03-2017 02:59 PM
New Contributor

I am having issues with ArcGIS Pro crashing when I export a layout to an image - jpg, tif, gif, pdf, etc. The project file will open, I am able to edit the data and layout, create new layouts, but am unable to exporting.

14 Replies
New Contributor

Using 2.9.0 and was having the same crash issue upon attempting to export layouts. Kory advised me that empty text elements in the layout can cause this, so I found/deleted them and it worked thereafter. 

New Contributor

I Had this exact same issue in 2.9.0 and found empty text boxes in the layout. After deleting the empty text boxes the layout was able to export. 

New Contributor

Solved the issue for me! Thanks!!

0 Kudos
New Contributor

This is a well known issue. The solution: There is probably an empty text component in the layout file. Simply delete this text file from the layout, and the export will work fine.

0 Kudos
New Contributor II

I am having similar issue with my ArcGIS 2.9.3. 

When I clicked the Export tab I opened previously, it shows "No active report, layout, or map" and froze, and shortly after ArcGIS Pro shut down silently without any Error report generated in AppData\Local\ESRI

I have a few guess so I did follow tests to exclude some potential causes

1. I opened another project. Its "Export" function works just fine.

2. I checked and made sure not only the active layouts, but also all the layouts don't have empty text elements which was identified as a common problem that caused similar crash.

3. I attempted to open the aprx in another machine that is using ArcGIS Pro 2.8.0. It didn't reproduce the same issue. The project file worked perfect in that machine and I ended up cleaning up the rest of work from there. So it is probably just the software in my machine that is having the Export issue. I have tried uninstalling and reinstalling, but it didn't resolve the issue.


What might be different with my ArcGIS 2.9.3

Before I had this issue, I upgraded my ArcGIS Pro to 3.0. Then I had another issue which is worth a separate post to discuss. Because of that problem, I decided to downgrade for now until I wrapped up my current project. What I did was to conduct a clean uninstallation by following this article. Then I re-install ArcGIS Pro 2.9 (2.9.3 is the version that is available in my company's software platform). 

0 Kudos