ArcGIS Pro asking for certificate

1640
10
Jump to solution
03-17-2021 09:32 AM
Labels (1)
JoshuaJohnson5
New Contributor II

Pro: 2.7.2

Starting Pro, a screen pops up:

SelectACert.png

This a new thing, and I have never seen it before. I do not know if I hit a setting in server manager (10.6.1), or somewhere else, that turned this pop up on. If I click "cancel", Pro works fine. If I disconnect our portal from Pro, the pop up does not appear on start. But then I have to reconnect, and get the same pop up.

Also, my organization is looking to use ArcGIS Field maps on iOS, and, after registering the app with the server, the app does the same thing, but will not allow a simple "skip".

 

How do I turn this off? Or generate a certificate? Or some other work around?

0 Kudos
1 Solution

Accepted Solutions
JoshuaJohnson5
New Contributor II

A solution has been found, thanks to our IT! It's a simple radio button that needs to be changed in IIS. Once open, drill down to:

<SERVER> > Sites > Default Web Site > click on portal

Scroll to 'SSL Settings' and double click.

You will have a checked box ('Require SSL') and three radio buttons for 'Client certificates'

Select Ignore.

Now portal should work, and you will have to do this same process for the server.

Simply click server (mine was on the same machine, right under 'portal')

This solved all the issues we were having. Duplicates of published maps/collected features/etc., collector and field maps not working, weird certificate errors for pro, and probably a bunch of other issues I never ran across.

View solution in original post

10 Replies
CraigRussell
Esri Contributor

Hi Joshua

Are you using HTTPS for your ArcGIS Enterprise implementation?  If so, do you get any certificate errors when you access Portal Administrator in your web browser, either via web adaptor (e.g. https://server.domain.com/portal/portaladmin) or direct access via port 7443 (e.g. https://server.domain.com:7443/arcgis/portaladmin)?

0 Kudos
JoshuaJohnson5
New Contributor II

Yes. IT has gone through every certificate on the web adaptor. I do not get any errors or warnings on firefox or chrome when accessing portaladmin via web adaptor or directly.

I get errors when accessing portal through Pro, as shown in the first post. I also get similar errors  on iOS when accessing ArcGIS Field Maps, which does not let me continue through.

I also get the errors on Android (8), however, like Pro, I can "skip", get to a portal log in screen, and the app works. But, our field workers use iPads, so we need iOS to work.

0 Kudos
CraigRussell
Esri Contributor

A few questions:

  • Where you have blacked something out in your screenshot, is that your portal URL or server name or something else?
  • Are you using SAML for authentication?
  • Are you using a licensing portal (either AGOL or your ArcGIS Enterprise)?
JoshuaJohnson5
New Contributor II
  • Where you have blacked something out in your screenshot, is that your portal URL or server name or something else?
    • That is the server name. I just went to that address, and I get a windows server IIS splash screen. In Pro, Projects tab > Portals, I am signed into two portals, one is arcgis.com, and the other is to the blacked out address, with "/portal/" appended to the end.
  • Are you using SAML for authentication?
    • IT tells me we are not using SAML, we are using LDAP
  • Are you using a licensing portal (either AGOL or your ArcGIS Enterprise)?
    • We are using ArcGIS Enterprise.
0 Kudos
CraigRussell
Esri Contributor

This might be easier for your local support to work through, but a couple of things...

That is the server name. I just went to that address, and I get a windows server IIS splash screen.

Do you get any HTTPS errors?  Are you using Chrome?

In Pro, Projects tab > Portals, I am signed into two portals, one is arcgis.com, and the other is to the blacked out address, with "/portal/" appended to the end.

So just to confirm, when you use your ArcGIS Portal in a browser, you go to an address like https://portal.domain.com/portal - is this different to the blacked out address?  e.g. it is something like https://servername01.domain.com/portal instead?  If so, you should try deleting that portal from Pro and adding the other one.

0 Kudos
JoshuaJohnson5
New Contributor II

I used both chrome and firefox, neither gave an error. I checked the web adaptor for the proper URL, and it is in the format of https://portal.domain.com/portal.

I have a call with ESRI tech support later today about this issue, and I will keep this thread updated.

 

UPDATE: Had a call with ESRI tech support. I showed the the issue with Pro and Field Maps (for both Android and iOS). We looked at the server and portal settings and he will be getting back with me on Wednesday. Fingers crossed.

0 Kudos
ShamarkAdgerson
New Contributor

Hello Joshua, 

Did you ever get the ArcGIS Pro certificate prompt issue resolved? I am experiencing the same issue when trying to add a portal connection within ArcGIS Pro. 

0 Kudos
JoshuaJohnson5
New Contributor II

No. I have been going back and forth with ESRI, checking settings for practically everything, and we have not come to a resolution. In fact, I am expecting a call later today.

One of our IT guys found a work around, however. Collector Classic works, so we are using Collector Classic until the issue is resolved, or we finally upgrade to ArcGIS Enterprise 10.8.1.

0 Kudos
ShamarkAdgerson
New Contributor

Thanks Joshua, 

I'll keep following you thread and if I am able to get a solution before you post one here I will share. 

Mark 

0 Kudos