Select to view content in your preferred language

ArcGIS Pro 3.1 setup terminates because it doesn't recognize Micosoft .NET Desktop Runtime (x64) v7.0

1198
4
08-29-2023 09:39 AM
SonarBATStructureMAPS
New Contributor III

1. Downloaded ArcGIS Pro v3.1.04.1833 install to new computer from 'My Esri' site.

2. Run ArcGISPro_31_184994.exe on new computer.

3. ArcGIS Pro setup program launches then message appears as follows: 

ArcGIS Pro .NET fail.png

4. Downloaded and installed lastest version of Microsoft .NET Desktop Runtime (x64) v7.0 <rebooted machine>.

5. Reran ArcGIS Pro setup program.

6. Same error appears immediately after ArcGIS Pro setup program launches and terminates setup. 

7. Reinstalled (Repair mode) Microsoft .NET Desktop Runtime (x64) v7.0

8. Reran ArcGIS Pro setup program.

Results: Issue persists: ArcGis Pro setup terminates becuase it doesn't recognize that Microsoft .NET Desktop Runtime (x64) v7.0 exists. 

4 Replies
DanPatterson
MVP Esteemed Contributor

From ArcGIS Pro 3.1 system requirements—ArcGIS Pro | Documentation

Microsoft .NET Desktop Runtime 6.0.5 or a later patch release (6.0.6 and so on), using a Windows x64 installer, is required. The presence of Microsoft .NET Desktop Runtime 7 or later is inconsequential.

Looks like you will have to install a 6.X version of Runtime


... sort of retired...
0 Kudos
SonarBATStructureMAPS
New Contributor III

Thanks, I googled "Microsoft .NET Desktop Runtime (x64)" and click on the Microsoft .NET download google returned. I assumed this was the .NET software Esri message was referring to. I didn't see an option for v6.0.5 on the Microsoft .NET download page, so installed v7.0. But I installed the wrong .NET software. After reading some more related posts in this forum, I realized that I should have downloaded/installed "Microsoft Desktop Runtime v6.0.6 (64x). So attention to detail is the key to avoid frustrations like this. However, it's very easy to download the wrong Microsoft .NET program due to the close similarities between what google returns using the keyword search I used, and what the ArcGISP Pro setup is expecting to exist on the target machine. After finding some more forum posts on this subject, it looks like this is common error users are making when installing ArcGIS Pro. Microsoft's naming convention for it's .NET products makes it very easy to confuse the average user which is doing a search for a specific .NET program/version. Perhaps Esri should update the ArcGIS Pro install notes/documentation to mitigate confusion when searching for .NET downloads. A link to the correct .NET download would help.  

Thanks for follow up. 

DanPatterson
MVP Esteemed Contributor

the links are on the link I posted under

Software requirements

Microsoft .NET Desktop Runtime 6.0.5 or a later patch release (6.0.6 and so on), using a Windows x64 installer, is required. The presence of Microsoft .NET Desktop Runtime 7 or later is inconsequential.

I have removed the links here, you will have to go the page I suggested.

Perhaps, the help topic can be improved to make the links more visible


... sort of retired...
0 Kudos
SonarBATStructureMAPS
New Contributor III

Thanks for the responses! 

0 Kudos