Anyway to override being locked out of ArcGIS Pro which was set up for offline use?

4052
6
05-29-2018 05:48 PM
TravisBrousseau2
New Contributor III

I recently set up ArcGIS Pro for offline use (through AGOL) as Pro wasn't performing well and was willing to try anything. Over the weekend, I used ArcGIS Pro for offline without any problems. Today, I’ve tried to use ArcGIS Pro and I’m getting the below error. Now, I’ve only used one workstation to authorize offline as well as the same workstation for ArcGIS Pro use. I haven’t used any other workstation for this yet I’m getting this error:

"The Account cannot be used to authorize ArcGIS Pro as it has already been configured to use in offline mode on some other device"

What I’ve tried: restarting the computer, uninstalling and reinstalling ArcGIS Pro, revoking license in ArcGIS Online without luck, trying to connect to Pro offline and online with several different network connections.

To confirm: I’ve used only one workstation with ArcGIS Pro the whole time.

Any thoughts on this?

6 Replies
DanPatterson_Retired
MVP Esteemed Contributor

The only surefire way is to go back to the computer that you signed it out on and undo the deed (Got caught once and hour before I had to teach a class).

I signed mine out through PRO itself, not through AGOL, so maybe that is the problem, you aren't in the right spot to fix it

0 Kudos
AmnoyAm
Esri Contributor

Travis,

Offline license of ArcGIS Pro will remain on the computer until you return the license.  Otherwise AGOL will continue to prompt the error you mentioned above when attempting to log into Pro on any other system using that account.  I understand you've been using just the one machine.  These are two scenario which may have occurred:

   1.  You logged into the system using account A and took the license offline.  Then later you logged into the system using another account, B for example.  Pro will start with the default AGOL login page because the offline license only applies to the Windows users it was taken offline for.  Of course you're attempting to log in with the same account.  Again AGOL let you know licenses were already taken offline for this account.  If this is the case, log into the system using the same account you used to take the licenses offline.  Then proceed to return the license.  

   2.  At some point you've attempted to return the offline licenses and failed or something odd had occurred where the borrowed licenses became corrupt.  The machine no longer acknowledge there is any borrowed license.  But AGOL says otherwise.  In this situation, you will need to contact our Tech Support or Customer Service to reset the account at the AGOL side.  

Hope this helps. 

TravisBrousseau2
New Contributor III

Hi guys. The tech support was great and reset the account. This was the only way forward.

Brownschuh
Occasional Contributor

I ran into this issue today.  Over the weekend I was experimenting with my work laptop at home; decided to check the box for offline use.  Fast forward to today, middle of the work week.  Was having unrelated, non-GIS issues with the same laptop, so I decided to re-image the machine.  Lo and behold when I reinstalled ArcGIS Pro I was prompted with the following error message after entering my AGOL username and password.  Called ESRI tech support and they were able to reset the license associated with my AGOL account.

 

AndresCastillo
MVP Regular Contributor

In portaladmin:

https://<hostname>:7443/arcgis/portaladmin/system/licenses/releaseLicense 

You can release the license with the username.

It might also be valuable to check the boolean value in the registry:

Computer\HKEY_CURRENT_USER\Software\ESRI\ArcGISPro\Licensing\ARCPROWORKOFFLINE

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\ArcGISPro\Licensing

ChrisRoot
New Contributor III

I ran into this issue, same error message as above.  It might have happend because I took my single user license offline several months ago, but I'm still not sure.  I disabled offline use many months back, but perhaps the license did not return cleanly.  I randomly got this error message after many months of using AGOL and ArcPro on a daily basis, I did not change settings in ArcPro or AGOL.  

The key in my case to getting someone at ESRI tech support to reset my license was to bring up this thread to them.  Apparently this glitch its not uncommon.  I just wish I could recuperate the cost of dealing with this, took opening multiple cases and most of a day.  Just go for the reset if you run into this, don't uninstall/ reinstall software or deal with software authorizations.  Just call tech support.

Be nice to have an explanation of what's going on, but it sounds like it may differ case to case.  ESRI could add to their current technical bulletin on this issue to make it more clear that its not something that people can fix on their own in some cases.

0 Kudos