2D animation export MP4 flickers with block white rectangle

09-09-2021 07:59 AM
New Contributor III

I'm simply trying to export a timelapse of 30 or so layers over a 10 year period. The output is awful, glitchy, flickering and a huge flashing vertical strip across it. 

It works in ArcGIS Online in the App (although not great, but it does work). It works in Pro if you play it from the 'Time' tab, but when it goes to the Animation tab it's an absolute nightmare. 

It's glitchy and incredibly difficult to work. It doesn't give you an option to show the full timelapse timer which is annoying, just a counter and the export is flickering and glitchy and has a huge vertical rectangle flashing every 3/4 frames. 

Things I've tried:

  1. I've made all layers "On the ground" with a cartographic offset of 0.01
  2. I've joined a lot of layers to see if they would work better and more seamlessly as one 
  3. I've done the opposite and broke each layer down
  4. I've tried different types of export frames and speeds
  5. I've cut keyframes to see if it's the length it struggles with
  6. I've tried different basemaps

The data all exists locally in a one GDB, all layers have simply a start and end time and a layer name. 

Nothing works. And each time I try it's over an hour to export to see if it worked again. This is just not on and from what I can see from other users this was so not ready to go live in Pro. I dread to think how it'll handle 3D and fly throughs. 

Please offer any solutions you can think of? 




0 Kudos
3 Replies
MVP Honored Contributor

Just to confirm, the white rectangle shows regardless of the basemap being used?

Have you tried exporting without a basemap entirely? Not that you'd want to for you final product, but just to see if that's where the issue is? Looking at your screenshot, it's hard to tell if the rectangle is something appearing over the basemap, or if it's simply a spot where the basemap isn't loading.

- Josh Carlson
Kendall County GIS
0 Kudos
New Contributor III

Yes, it shows regardless, and the rest of the basemap flickers as well.

I've tried with a Topo basemap and with nothing and it still happens. It didn't happen the first few times I exported though, but the issues then were that some of the layers would flicker throughout. Even when the layers were separated from another layer that was moving through time. It looks awful. 


0 Kudos
Esri Contributor

It may help to know the graphics card and memory (both graphics and overall) in your hardware. I'm no expert on such things, but this kind of performance seems memory-oriented.

0 Kudos