Refresh Domains

713
17
11-17-2019 06:05 PM
Status: Open
Labels (1)
MicheleHosking1
Occasional Contributor

I have just finished adding many domains to a new enterprise geodatabase using the Table to Domain tool.  However even after refreshing the database connection when I open the Domain view all the domains I just added do not show up.  I tried removing the database connection and adding it to the project again but with the same result. 

It appears the only way to make these domains show in the Domain view is to close ArcPro and open it again.  This seems clumsy.  It would be great if the refresh of a database connection would actually pull back all changes.  It's a pain to have to close ArcPro just to see this sort of thing.

17 Comments
KoryKramer

It sounds like you are describing what was reported in this bug: BUG-000085913: The Table To Domain tool does not show the new domai.. which is marked fixed in ArcGIS Pro 2.4.  If you are running ArcGIS Pro 2.4.x and are still experiencing refresh issues with domains, I would recommend contacting technical support to troubleshoot.  Esri Support Contact Support 

Thank you!

MicheleHosking1

Yeah - I have 2.4.2 so not fixed for me.  I'll pass it on.  Thanks.

KoryKramer

Hmm, sorry, Michele.  If the Domains View is closed and re-opened it still doesn't pick up the new domains?  That bug may need to be re-investigated if the status is incorrect.

MicheleHosking1

I'm pretty sure I closed it and opened it. I think that would have been the first thing I did - but I'll test that again to make sure.  I also removed the geodatabase connection and added it back again, and tried refreshing the connection - all to no avail.  Be cool if it could be re-investigated.

Thanks very much.

KoryKramer

Hi Michele, I changed this idea back to Reviewed as I have now tested and the only way I'm able to get the domain values to update is to close and re-open the project (or open a new instance of Pro).  Closing and opening the Domains view itself did not work for me either.  So I'm in touch with the appropriate teams to re-investigate why BUG-000085913: The Table To Domain tool does not show the new domai.. has a status of Implemented.  It is probably just a mistake - I apologize.  We'll pursue this.

Thank you!

MicheleHosking1

Awesome - thanks for dealing with this.

KoryKramer

No problem - but I may have been too fast replying that closing/opening Domains view doesn't work.  We've had others look at this, and when I tried again in a different project, that works.  Anyway, just out of curiosity, does that work for you?

I think all can agree that ideally the view would update, or have some sort of refresh functionality, so we will keep this idea open.  But it would be good to understand from users reporting this if closing/opening the view works.  This should have been the part addressed in Pro 2.4...

MicheleHosking1

My process is this:

  1. Domain To Table (from a 10.2.2 enterprise geodatabase)
  2. In ArcPro - Domains view already open
  3. Table to Domain (to a 10.7.1 enterprise geodatabase)
  4. Doesn't show up in Domain view
  5. Close and open Domain view - still not showing
  6. Close Domain view, refresh database connection, open Domain view - not showing
  7. Close Domain view, remove database connection from project, Add database connection to project from favourites, open Domain View - not showing.

Alternatively:

Same as above except I didn't open the Domain view before running the Table to Domain tool

Open Domain view - not showing.

Tried opening the Domain view by opening an attribute table first and getting to the Domain view from the ribbon - not showing.

The only way I can get the new domains is to close ArcPro and open it up again.

Hope this helps.

P.S - I'm doing all this in a unsaved project.  When I'm doing this sort of thing I don't want to save it as a project.  Not sure if that makes a difference?

KoryKramer

Do you have a map open containing layers that use the domain you're updating?

KoryKramer

I found it vexing that in my first project where I was testing this I didn't find closing/opening the Domains View to work.  So I went over to an Untitled project and tested.  Lo and behold, closing/opening Domains View did display the updated domain values after running the tool.  

Why?  

As far as I can tell from my testing, I had no map open, meaning no layers using the domains I was updating.  In that scenario, the values updated by just re-opening the Domains View.

In the project where I didn't see it working, I had map layers that used the domain.  If I remove the layers, close/re-open Domains View, the values are updated.  Then re-add the layers.  

Mind you, I'm not saying this is all well and good.  Just sharing my findings.  Is what you're seeing the same?

Tyler Schwartz