ArcGIS Pro 2.6: How to enhance the “feature class to feature class” tool to be able to keep reorderi

671
9
11-17-2020 08:40 AM
Status: Closed
Labels (1)
JamalNUMAN
Esteemed Contributor

ArcGIS Pro 2.6: How to enhance the “feature class to feature class” tool to be able to keep reordering the fields in the output feature,

 

It would be great if the “feature class to feature class” tool is enhanced to to be able to keep reordering the fields in the output feature.

 

Currently, the output doesn’t respect in case the fields are reordered in the tool

 

 

 

In the screenshot below, F3 field is moved to be to the left of F1. As the tool is run, the output keeps the fields in their original positions!

 

Clip_275.jpg

9 Comments
KoryKramer
Status changed to: Needs Clarification

Hi Jamal,

I see that you're posting this as an "enhancement" to the Feature Class to Feature Class tool, but if we look at the tool's documentation, Feature Class to Feature Class (Conversion)—ArcGIS Pro | Documentation , we see that reordering fields in the field map is expected to work.  

"All fields in the output dataset and the contents of those fields can be controlled using the Field map.

To change the field order, select a field name and drag it to the preferred position."

If I understand your post and image correctly, that is what you're doing, correct?  You're dragging the fields in the field map to reorder them, and then you're saying that the field map's field order is not respected, correct?

If that is the case, this is a bug and should not be submitted as an idea.  Please refer to the ArcGIS Ideas Submission Guidelines and Statuses 

The bad news is that I see the behavior you're describing in 2.6.3.  The good news is that I do not see this behavior in 2.7.  

Please let me know if I'm understanding the problem correctly.

Thank you!

KoryKramer
Status changed to: Closed

Hi @JamalNUMAN 

I checked this again in ArcGIS Pro 2.7 and when I reorder the fields in the Feature Class to Feature Class tool, the order is respected in the output.

If you continue to see an issue or experience unexpected results, please contact technical support to investigate further.

Thank you!

JamalNUMAN

The issue persists to exists as per the screenshots below. It appears that no enhancement on this

 

Clip_128.jpgClip_129.jpgClip_130.jpg

KoryKramer

Hi Jamal,

I can see from your screenshots that the field is not reordered as expected.  I tried again just now in ArcGIS Pro 2.7 and I see the tool working as expected:

KoryKramer_0-1609162147858.png

So we're obviously missing something important that is needed to reproduce the issue.  As I said in my comment on Wednesday, this should not be treated as an idea, rather an issue that needs to be worked on with technical support to figure out how to reproduce the behavior you're demonstrating in your screenshots.

Thank you.

JamalNUMAN

Thank you very much Kory for the elaboration. Your distinct efforts are highly appreciated

 

Best

 

Jamal

MajdoleenO_A__Awadallah

Hi @KoryKramer ,

 

Unfortunately, I end with the same behavior as @JamalNUMAN , it seems that their is a bug in this tool and I am using arcpro 2.7.

f1.pngf2.png

KoryKramer

Hi @MajdoleenO_A__Awadallah 

Unfortunately I don't think that your screenshots get us any closer to figuring out how to reproduce what you and Jamal are seeing.  I saw that you were using a polygonZ feature class and that Jamal was as well in his screenshots.  So I tried to reproduce (again!) but this time with a polygonZ feature class.  You can see that my original feature class has fields m1, m2 and m3 - I'm trying to replicate what I can from your screenshots.

KoryKramer_0-1609787894045.png

See in the tool's Field Map that I reordered those to m3, m2, m1.

With the exception of the Shape_Length and Shape_Area fields moving to the end, I see that the field order set in the tool is respected.

KoryKramer_1-1609788085747.png

Since both you and Jamal are experiencing an issue where it appears that the output order does not respect the order you set in the tool, please contact technical support to report this as a bug, with specific steps to reproduce the issue.

Thank you!

 

JamalNUMAN

 

Thanks Kory.

 

It’s quite straightforward to replicate the issue. The screenshot below gives a plan in how to reproduce the issue. Also, the feature class that never respects fields reordering is there in the link below

 

What do you think?

 

data:

https://www.mediafire.com/file/6to2mqvgigt2lo4/H.gdb.zip/file

 

 

Clip_161.jpgClip_162.jpgClip_163.jpgClip_164.jpgClip_165.jpgClip_166.jpgClip_167.jpg

KoryKramer

OK, Jamal.

I gave it one last try with the data you sent.  The reordering works for me.

KoryKramer_0-1609790377971.png

I think we're going to have to call it quits on trying to troubleshoot this on this thread.  It will require more in-depth troubleshooting if a bug is to be logged - and that will need to be done through technical support.  

Thank you!