Parcels not building

1176
10
03-24-2022 07:38 AM
Labels (1)
anna_garrett
Occasional Contributor III

Has anyone else run into this? I have some stubborn parcels that won't build.

- There are no dangles

- Everything is in the same record

- Topology check returns no parcel errors - to be expected when there is no polygon to match the lines

- Seeds created with appropriate types for my fabric

- All surrounding parcels built with no problem

 

I don't really have time to submit a ticket and go over it with support, just looking to see if anyone else has run into this. Going to manually draw in the polygons I need and move on. 

0 Kudos
10 Replies
jcarlson
MVP Esteemed Contributor

My co-worker hits this sometimes. I can't say why this happens, but it seems to be machine-specific. If I open his version and attempt to build the same parcel seeds, they will build. I suspect restarting Pro on his machine would do it, too, but I haven't checked.

- Josh Carlson
Kendall County GIS
0 Kudos
JeffWard
Occasional Contributor III

If I use the Copy Lines To... tool this will happen to me at times. It usually happens when I'm copying the lines from my lots subtype to my tax parcels subtype - a small line doesn't make the trip to the tax parcels. Not sure why it happens.

I have run into parcels not building because they aren't completely within the current extent - the default build button is "Build Parcels in Current Extent".

Jeff Ward
Summit County, Utah
0 Kudos
AmirBar-Maor
Esri Regular Contributor

Make sure you only have one parcel seed.
The easiest thing to do is to select the Seed and see how many features are selected (bottom right of the map).
This can happen if you selected 2 parcels by mistake - for example, the lot and the tax parcel.

In 3.0 we have enhanced the seed label class to show a label if there is no parcel name which makes it easy to detect.

anna_garrett
Occasional Contributor III

@jcarlson Sometimes that will work to clear odd behavior (like when the ribbon stops responding) but that didn't clear that one for me. 

@JeffWard I avoid that tool if I can avoid it! pretty easy to mess up, imo.

@AmirBar-Maor I have done that by accident before, but not this time. I found at least one spot where a line overlapped another and the endpoint was snapped to a vertex instead of the other line's endpoint but that was only the case for one of the parcels that did not build. the ultimate route I took was to sketch in the polygons, which isn't great but in my case there were only a handful and my lines were straight off the plat. 

Thank you for the heads up about the new label class for seeds, I have custom label expressions and will need to back those up before updating to the new version. Is there anything parcel seed specific that I might need to worry about? I also have custom symbology that I absolutely can't lose. Fwiw those are already backed up elsewhere but knowing ahead of time that I'm going to have readjust everything would be tremendously helpful.

0 Kudos
AmirBar-Maor
Esri Regular Contributor

@anna_garrett 

I know you are busy, but if you select and copy out that area using the geoprocessing tool Copy Parcels and summit it to technical support we can have a look to figure out why it is not building.

Will we continue to improve the default symbology and label classes?

Yes. and every time we do improve them it will be up to you to decide if it is worth the effort to adopt it. We will try to also show how to do that in the next meetup. 

Build will only build from a seed if there is:

  1. A closed loop of lines
  2. All lines belong to the same record
  3. There is exactly one seed in the closed loop
  4. The entire seed is in the map extent (if using Build Extent)

 

anna_garrett
Occasional Contributor III

If I still had the uncorrected version I would send a copy to support, unfortunately it's long gone. Next time I run into this (and I might, who knows I have 7 more 2023 subdivisions to digitize right now and if this one is any indication of what's to come, lmao) 

Thank you for the seed refresher, though. I almost always have build plan as my default because I ran into parcels not building outside of the extent too often, haha

 

0 Kudos
WileyBogren
New Contributor III

I ran into something similar with an old dataset a while ago; one or two parcel corners out of my whole haystack had a very small line (right around the minimum tolerance value, .003ft or whatever it was set to) that was centered on the corner, overlapping and dangling  a distance less than the tolerance value into the lines on either side.

These little micro lines, or splinters, or whatever would completely block the entire build parcel fabric process so that nothing would build, unless I selected an extent that excluded those corners. So that was how I eventually found them and purged them, by selecting extents that built and gradually shifting and expanding the boundaries of those successful extents until I had found the points (/splinters) that were blocking me 😄

0 Kudos
anna_garrett
Occasional Contributor III

that might honestly be my problem. I noticed that I had a similar extremely short line that was messing up my build after the problem I posted about. 

 

looking forward to the fixes and new tools in 2.9!!

0 Kudos
AmirBar-Maor
Esri Regular Contributor

If very small lines are the culprit, we introduced the ability to detect very small lines using a layer in ArcGIS Pro 2.9.
From the quality tab you can add the 'Too Short' layer and view any small lines that should be eliminated.

The Merge Parcel Points tool is a useful tool to use for that process (just make sure to check the option to remove lines in the bottom of the tool)

AmirBarMaor_0-1649662127605.png

 

And as always, the development team can only hypothesize - if you think you encounter a bug it would be best to content technical support and provide them a sample data.  

0 Kudos