Why can't I continue configuring the pop-ups on my AGOL map?

10710
26
Jump to solution
09-01-2016 11:22 AM
BrianO_keefe
Occasional Contributor III

I have a map on AGOL that we have created a Web Map for via WAB. It's been in production, on an internal server (so no, I can't share the url), for a few months now. I got a service ticket today to add the OBJECTID to all popups for all feature classes. Please don't tell me why this is a bad idea, I already know.

Mine is not to question why, Mine is just to eat the pie.

SO ANYWAY, I am on AGOL configuring the pop-ups when 8 layers in clicking on CONFIGURE POP-UP for a layer does nothing. Not a thing.

I try to click on other CONFIGURE POP-UP for other layers... nothing. I try to do this for layers I've already added OBJECTID... nothing. I can click on the map and see my brand new popup configurations and there is the OBJECTID... but I cannot change it anymore.

On any layer.

I have rebooted even thinking it might be a weird browser issue... nothing.

No more editing the pop-ups...

Here is a quick screencast showing my frustration...

ArcGIS Online Popups Not Configurable Suddenly - YouTube  

Any ideas?

Tags (1)
1 Solution

Accepted Solutions
BrianO_keefe
Occasional Contributor III

We discovered that ESRI Shape fields have to be at the bottom of the list. If the Shape fields are in front of ANY OTHER FIELDS then those fields will NOT be visible or editable. Apparently, AGOL can't process an ESRI specific field for some reason.

View solution in original post

26 Replies
BrianO_keefe
Occasional Contributor III

To confuse the issue even further...

If I go into Incognito mode, it works but only on my supervisors computer / account.

Otherwise, none of my co-workers can edit... I can't edit... except randomly... and then the configure option goes away immediately afterwards.

0 Kudos
JakeSkinner
Esri Esteemed Contributor

Hi Brian,

I'm curious if you do a 'Save As' on the web map to save it as a new web map if it works.  Troubleshooting to see if it's something with this particular web map.

0 Kudos
BrianO_keefe
Occasional Contributor III

No sir. Still just "Configure Popup" > CLICK > Nothing

0 Kudos
BrianO_keefe
Occasional Contributor III

Does anyone have any idea how you upgrade a request like this to a service ticket with ESRI?

This is a serious glitch with a production system. It replicates across any of our computers here. You cannot edit those feature layers except randomly. You can click 'Configure Popup' a hundred times and it will suddenly work once out of too many... 

HELP!

0 Kudos
JakeSkinner
Esri Esteemed Contributor

I would recommend calling Tech Support at 888-377-4575.  They will get you in touch with an ArcGIS Online analyst immediately.

SteveGay1
New Contributor

We are experiencing this issue today.  Can you confirm if this is a bug that has been logged that will be addressed or is it simply going to be a known limitation?

0 Kudos
CarmelConnolly3
Occasional Contributor II

Hi Brian,

We've had this issue happen to us recently as well. Have you find you cannot change the symbology of the layer as well?

I've also found that the shape field of the layer was having an impact. It was turned off when I first published the layer. Turning it on and overwriting did not fix the issue but publishing it as a brand new layer did.

Carmel

MikeMinami
Esri Notable Contributor

Are you using Chrome browser? Can you try a different browser if so? There is an issue with the latest version of Chrome. Hopefully, Chrome will issue an update.

Update: It looks like Chrome has released an update.

Mike

by Anonymous User
Not applicable

Hi Brain - I've just been struggling with the same issue, for me it occurred when we modified the schema of a feature class to add a few more attributes which I wanted to use in the pop-up window.

For any existing feature layer in the map service I could enable/disable the pop-up but not configure it. I did not want to recreate all the custom pop-ups on the multiple layers in the map service. I tried everything on all the forums I found, brand new MXD, adding layers again, republishing, etc. but none worked for me.

After lots of tests what I had to do was go back to the original MXD and then in the properties of each feature layer that the data source was from the feature class with the modified schema, in the fields tab of the properties, Select Options and Reset Field Order.

After I did this on layers that referenced that feature class I could configure the pop-ups again as I wanted.

Could be specific to my situation due to the schema change, but it solved my problem.

Thanks,

Dave