Web Map Layer Search List Not Updating Properly

137
3
Jump to solution
06-27-2022 02:03 PM
Labels (1)
ArvadaColorado
New Contributor II

I have a web map that contains features from our water network. Users of this map need to be able to perform searches on a number of layers included in the referenced map service. Specifically, they need to search Hydrants and Service Laterals by their ASSET ID field. This is a string field (no domains). 

Whenever I try to add a new layer to base a search upon, the dropdown for the attributes appear to be locked to a different layer in my map. The other layers have the QUERY operations enabled so I'm not sure why it's getting hung up. 

I've created a sample map to test this and I can't even access the Search Layer settings if using the same layer. I can enable the By Layer option but then it fails to bring in any drop down to add a layer. I can't save it without layers apparently either as it hangs and hangs eventually stopping. Other web maps that do not include this layer do not seem to produce the behavior so I assume it has something to do with the high number of layers in this service (30+). It's odd since we've only run into problems attempting to update it today with recent change requests. No issues like this have been experienced prior. 

ArvadaColorado_0-1656364703436.png

 

TDLR: The attribute list for search by layer configuration won't update to show the attributes of the new layer selected. 

1 Solution

Accepted Solutions
ArvadaColorado
New Contributor II

Looks like this issue sort of resolved itself. A colleague was able to make the update a few days later without the issue replicating.. 

View solution in original post

3 Replies
EllenNodwell_IntegraShare
Occasional Contributor

Over the past few days I have found issues with some of my layers - sporadic - and it's an overwhelming situation to try to troubleshoot every layer without some sort of auditing capability like we might have with ArcGIS Server, so I have been testing the applications and maps that we expose as our examples in our gallery, as well as some that are otherwise required to work for customers. 

On one of my layers, I tried to filter out all but one specific feature, and it worked at first - I saved my map, then I viewed it and it's like it forgot.  I went in to edit it and couldn't get the filter to work on that layer.  I couldn't see what the problem was, so I suspect it must be something related or something is corrupted.

Like you point out, I've found that I can't get to the controls in some of my published feature classes, sometimes I get a permissions error.  I've even opened some of these up in ArcGIS Pro to try to troubleshoot the data better and interestingly, on the few that I have looked at, the data is still there, so if I were guessing on what this is - it might be something broken in the presentation layers of AGOL Who knows?

Hopefully, Esri will fix it pronto since whatever this is seems to be affecting quite a number of people. Fingers crossed!

Hang in there and fingers crossed!

fjramos
New Contributor II

I'm having the same issue too

0 Kudos
ArvadaColorado
New Contributor II

Looks like this issue sort of resolved itself. A colleague was able to make the update a few days later without the issue replicating..