Updating/appending data of feature layer does not properly update data in infographics?

4291
12
10-24-2020 04:47 PM
JennyKuan
New Contributor III

Hi,

I created a Web Map with two different infographics displaying the number of votes per political party/candidate. These numbers will need to be updated every ten minutes or so, and I tested out whether "Update Data"/"Append data to layer" would properly update the data inside the infographics. It did something very strange - instead of displaying the proper numbers in the updated table, it multiplied the values! I have appended the table multiple times now but, it keeps multiplying the values - in this instance, multiplying the number of votes. 

I want to be able to click the box "Update existing features" but it is grayed out. I have unique IDs in my Excel sheet but for some reason, it does not show in the Feature Layer table.

Has anyone ever experienced something like this before?

Please see screenshots below for reference.

Thank you,

Jenny

Tags (3)
0 Kudos
12 Replies
by Anonymous User
Not applicable

@DataOfficer 

I got a warning that you do not have private messages enabled. If you go to your profile settings > preferences > toggle the drop-down to private messenger > you can turn this functionality on if you wish. Here is what I would have sent via a DM:

Testing:

  • I initially published the layer from an exported FGDB
  • Setting Ref_uniqueID values as unique failed
    • The error message was that the field was not unique - confirmed in Excel that the field is unique. Not sure what was going on with this and it may warrant some further research. However since this isn't the issue we're currently troubleshooting, worked around it for now.
  • Successfully used Python API method clone_items to copy the layer
    • This maintained the setting of the Ref_uniqueID field as unique
    • Tried to append records from incl. csv (update existing features was grayed out)
  • Looked at settings of cloned feature layer and noticed that Keep track of created and updated features was checked on and grayed out. This is the change tracking setting, different than keep track of who created and updated features. From the append doc: "You can only add new data to a hosted feature layer that has synchronization or change tracking (Keep track of created and updated features) enabled."
  • I then looked at the admin endpoint of the layer and viewed the service definition. I noticed that there were settings that indicated change tracking had been enabled on hosted feature layer views: "hasChangeTrackingEnabledViews" : true
    • I'm thinking that since I cloned this layer from your hosted feature layer, it copied across the entire service definition, including information that the layer has views with certain properties.

Suggestions:

  • From everything I can tell, change tracking is preventing using append to update existing features at the moment.
  • I would look at the views created from this hosted feature layer and see if they have change tracking enabled, and if they do, evaluate if it is a requirement. If not, then you can toggle this off on the views and then ultimately on the hosted feature layer. 
    • I expect that this will enable updating existing features when appending. 

 

I hope this helps, let me know how it goes. 

Thanks,

-Peter 

0 Kudos
DataOfficer
Occasional Contributor III

@Anonymous User,
For some reason Private Messenger isn't an option in my settings.
Thank you for looking in to this. I have now disabled Keep track of created and updated features in both the hosted view layers and the hosted layer itself. However, Update existing features is still greyed out in the Append Data window. 

0 Kudos
by Anonymous User
Not applicable

Hi @DataOfficer - thanks for changing this setting. Cloning the item I can confirm that the service change tracking setting is no longer there, which is good. 

On the cloned service, I am also given the opportunity to append with updating features and selecting the Ref_UniqueID field as the unique identifier. However this hangs and does not complete. The oddity with the unique IDs mentioned above when republishing from FGDB (the error message that they are not unique) was added to when I downloaded the hosted feature layer as a CSV; it only exports about 1/4 of the records. However when I publish this subset as a hosted feature layer, I can append with update features and use the Ref_UniqueID field as the unique identifier. 

Would it be possible to add to the Online group or send to pklingman@esri.com a source copy of the data that hasn't been published to Online as a hosted feature layer? I want to take the existing service out of the picture and try a test workflow start-to-finish with the data. 

Thanks for your help and patience on this one,

-Peter 

 

0 Kudos