Time slider infographic filtering

687
9
07-02-2018 09:13 AM
RobertPhillips
Occasional Contributor III

Hi,

I was wondering if it might be possible to enable the time slider in the web app builder dashboard to filter the layers so that the infographic widget updates based on the time slider drawing layers. I know that currently the inforgraphic widget does not filter in conjunction with the time slider but I was just wondering if it could be done.

Thanks,

Robert

9 Replies
AndrewKelly2
New Contributor

Did you ever find a way to do this?

0 Kudos
RobertPhillips
Occasional Contributor III

No, I haven't been able to lately. I can manually filter dates but I

haven't checked lately to see if anything has changed.

0 Kudos
JasonSmolinski
New Contributor III

This absolutely needs to be added to the WAB.

RobertPhillips
Occasional Contributor III

Yeah it really does. If there isn't an idea for it feel free to create one. If not, I can go ahead and create it.

MichaelClementz
New Contributor II

I haven't seen any updates since April so it looks like I am next in line to ask whether this functionality has been added to WAB. Has anyone heard if Esri is planning to add the functionality?

0 Kudos
RobertPhillips
Occasional Contributor III

I've been waiting for updates still but I think Esri might have other pressing matters. Hopefully they can get to it eventually. 

0 Kudos
sapnas
by
Occasional Contributor III

I was able to modify time slider code to update the infographics widget. I have tested this in webappbuilder developer version  but not tested in arcgis enterprise portal. 

https://community.esri.com/docs/DOC-14732-time-slider-enhancement-to-auto-update-infographics 

0 Kudos
RobertPhillips
Occasional Contributor III

Thanks Sapna.

   I hope they could eventually add the improvements to ArcGIS Online since it would only make sense to do so. I can try and see how it will test on our portal and let you know if there are any issues.

0 Kudos
PatriciaAndolz
New Contributor

Hi @sapnas I have tried your widget but when I execute the time slider, all the data is deleted. I mean, the layer desapeares and in the Infographics widget appeares a "No data" error.

What am I doing wrong?

Thanks.

0 Kudos