Symbolizing based on two fields in webmap

649
3
02-12-2020 12:05 PM
ChandlerCallison
New Contributor III

I have a map change request feature that allows field crews to submit notes on incorrect info in the map. I have it symbolized for whether its a water or sewer problem. There's also a status field that shows whether the request is open or has been resolved. Once the request has been resolved, I don't want it to show on the map anymore. I tried to do that by adding a custom expression as a second attribute in the webmap symbology, but for some reason it won't stick. I type the arcade expression, hit ok, but when I get back to the symbology pane it's still only showing that I'm symbolizing based on one attribute. What's the problem? Can I not symbolize based on a field AND a custom arcade expression?

0 Kudos
3 Replies
XanderBakker
Esri Esteemed Contributor

Hi Chandler Callison ,

I think I am seeing the same thing here. I selected a field as first field and created an expression as second field and that expression was not applied. When I look a little further, I notice that the second field should be numerical (when the first is text). So your arcade should return values not strings.

Wait, let me rephrase that... You cannot have two text fields to create your symbology. If you want to create symbology based on two text fields or a text field and an Arcade expression that returns text, it is better to extent the expression to concatenate the first field with the original arcade expression result and use this single field for your symbology.

0 Kudos
Annina_Hirschi_Wyss
Occasional Contributor

Xander, I did exactly the same thing (concatenate with arcade two text fields, they are domains) like this:

DomainName($feature,"First-Field") + ", " + DomainName($feature,"Second_Field"

This works fine in the classic viewer, BUT: when with the Beta Viewer and/or Experience builder it's all grey (my colour for "other" values).

Can you reproduce this as well?

Katie Cullen‌, Kelly Gerrow‌ : Is this a limitation of the V4 map viewer? Will it be resolved? Timeline?

Thx

Annina

0 Kudos
DavidCarpenter
Occasional Contributor

Just checking in on this since I ran into the same problem using the new Map Viewer which is no longer in Beta while trying to create a web map for use in Field Maps.   

I need to concatenate two text fields in an expression for the layer symbology and was getting an error indicating a number was expected.  I saw this post and then switched the map to the Classic Viewer and had no issues.  Is this issue slated to be resolved in the next release and I assume the work around would be to stick with the Classic Viewer?

Thanks.