Service Area Layers Not Rendering Properly in AGOL

347
1
08-01-2019 08:42 AM
OscarSepulveda_III
Occasional Contributor

I have developed service areas within ArcGIS Pro (v.2.4.0) based upon the following settings:

Network Analyst Settings

with Travel Settings:

  • Restrictions
    • Driving an Emergency Vehicle
  • U-Turns
    • All
  • Advanced
    • Use Hierarchy
    • Simplify Output Geometry

AND I imported a point layer (Fire Station Locations)

I ran the analysis and the outcome rendered properly as shown below.

Correct Service Area Layer Rendering

Then, I published a feature service to AGOL that included all 5 cutoffs.  But, when I viewed the feature layer in AGOL the layers did not render properly.  

Incorrect Service Area Layer Rendering

I have tried sorting the table by Cutoff Time back in Pro without success.  Also, moving the layers in the symbology editing field in AGOL without success.  And I can't perform the network analysis in AGOL because I am using the 'Driving an Emergency Vehicle' restriction.

ANY IDEAS????

0 Kudos
1 Reply
Peter_Klingman
Esri Regular Contributor

Hey Oscar Sepulveda III‌,

I would recommend creating a Support Case to look at the rendering issue. I haven't seen that specific issue before but Support will be able to take a closer look at the data and workflow. 

It is in fact possible to perform network analysis in ArcGIS Online with the Driving an Emergency vehicle restriction. Please see the documentation here about adding restrictions to custom Travel Modes: https://doc.arcgis.com/en/arcgis-online/reference/travel-modes.htm#ESRI_SECTION1_062FBD1B57004A3D85D...

Hope this helps,

Peter

0 Kudos