Removing numeric separators in legend/key?

175
2
03-26-2019 06:50 PM
ErinWarford
New Contributor

When adding numeric data to ArcGIS Online, it automatically adds numeric separators after every 1000. I understand that I can change the settings so that the numeric separators will not be used in the pop-ups or attribute table, but this does not change the values in the legend/key. Is there a way to make sure that the numbers in the legend/key will appear without the numeric separators? I am trying to symbolize data by year, and I really just want it to appear as "2019".

I am adding a .csv to ArcGIS Online. I am using the free version, not the paid version. I have tried making sure that the field was formatted as text, but this did not solve the problem.

Any advice appreciated!

0 Kudos
2 Replies
StephenM
Occasional Contributor II

If you're using unique symbols to draw the layer, you can change the labels in the legend by going to Change Style -> Options.

change style button in ArcGIS Online

style options button in ArcGIS Online

style options details in ArcGIS Online

0 Kudos
KellyGerrow
Esri Frequent Contributor

Another option is to select the field type of string or date during the publishing process when you want to display the year as a year and not a number. This will ensure that thousand separators are not visible by default.

-Kelly

0 Kudos