Publishing Services via ArcGIS - Services - strange behaviour

3404
4
05-21-2015 07:09 AM
ThomasSteudel1
Occasional Contributor

Dear all,

today i wanted to update an existing service (overwrite it). I did this procedure many times before but today i see an empty window within arcgis.

I am using ArcGIS 10.2.2

I load my project mxd with the layer i want to update

I choose publish service via the File --> Publish service --> update an existing service

Normaly i am getting a list now, where i can choose which service i want to update. But today this list is empty. I have no idea why and how i could fix this problem.

I am still able to see all my serices which i published in ArcCatalog as well as in the arcgis server manager.

Also i am able to publish a new service without any problem. But in all cases the following window stays empty:

Unbenannt.PNG

I really did not change anything

Does someone has an idea why it is empty and how i can solve it?

All services are working fine.

Thank you in advice and best regards Thomas

0 Kudos
4 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Thomas,

Are you connecting to the correct ArcGIS Server connection?  Were you previously connecting to an admin, instead of a publisher, connection?

ThomasSteudel1
Occasional Contributor

Hi Jake,

i previously connected to the same Server Connection as shown within the figure.

If i open ArcCatalog it looks like this:

Services_Server.PNG

The strange thing (to me) is, that all services are listed within the arcgis on a-gis_6080 (Benutzer = user) connection. Within the Publisher and the Admin connection nothing is listed.

Furthermore i can only choose between these two connections shown in the following figure:

Normaly i used the Publisher connection and everything worked fine. But now as you can see in the first figure, the services moved to the "user" connection. How is this possible?

Options1.png

I am really confused because i am not that deep into this server configuration topic.

Thank you in advice,

Thomas

0 Kudos
StevenGraf1
Regular Contributor

Try removing the connection from Catalog, close all Arc sessions.  Open Catalog back up and add the connection back in.

See if that does the trick.

Steven

ThomasSteudel1
Occasional Contributor

You wont belive all services appeard again in the publisher connection. Also within the "overwrite services" window as well as within ArcCatalog.

The thing what i did today before i saw the problem was, i just published a service within a subfolder (called UF). Now i tried to publish the same service within the "Stammverzeichnis" - Main Directory and then trying to overwrite this published service. And then all other services appeared again.

Is this some kind of a temp Bug or do i need to consider something the next time?

2.PNG

3.PNG

I hope it was just a temporary thing, because i can not explain it otherwise.

Thank you both for your answers.

Best regards,

Thomas

0 Kudos